Jump to content

All Activity

This stream auto-updates     

  1. Past hour
  2. Last week
  3. Hi I tried to install LINX through VIPM, but error occurs. followings are entire error messages: Main Package Name: Digilent LINX (Control Arduino, Raspberry Pi, BeagleBone and more) v3.0.1.192 Package Name with Error: Digilent LINX (Control Arduino, Raspberry Pi, BeagleBone and more) v3.0.1.192 Error Message: VIPM could not install the package lvh_linx-3.0.1.192 . Error Code: 42 Error Source: D5566ECD6962606ED717A0810948FA29->0AF9339C77424DFA92DA38FDE74DE74C->4E1CC4C6560AE3803601B09E181DEFA6->OGPM Class.lvlib:89AC7BADF759B8183E200C1F7AFA7855->OGPM Class.lvlib:3617A98EB64CF6012064A2A881466B07->579BE417495B7ADCD1FF111EE165D832->VIPM Main Window.vi 안에 VI 참조 열기<APPEND> I use labview 2012, window7, and the latest version of vipm.
  4. Hi @Jonathan. I'm glad you find the JKI tools helpful! It's possible, but will probably take some tweaks. There's a post here about how to use a Proxy with LabVIEW's built-in HTTP client VIs, which the JKI HTTP REST Client uses, under the hood. If you need support in figuring this out and implementing a solution, you can also Contact JKI to discuss your project.
  5. Hello everyone, Fist of all thank you for your Tools that are very helpfull. I'm trying to use the HTTP JKI REST drivers with an HTTPS website but I need to go trough a Proxy. How is it possible to desribe the PROXY settings with this driver? Thank you by advance.
  6. There appears to be a bug when decoding an empty 2D array using "JKI JSON Serialization.lvlib:Unflatten From JSON String.vi". When the variant that comes out of the Unflatten vi is passed into the Variant to Data vi, it causes an error 91 to be thrown. Looking at the variant produced, the problem appears to be in how the array dimensions are reported in the variant. The variant from the Unflatten From JSON String shows: "[0]" where just taking an empty 2D array and converting it to variant shows: "[0x0]". JSON 2D Array Error.vi
  7. Earlier
  8. It is about four years later, I'm re-installing EasyXML, and this Example is still broken. The newly-installed Package still has the 4-year-old "wrong" Address, not the "corrected" one listed above. Why not put the "right" address in the Package? When I manually put the corrected address in and tried to run the example, I got "Error 1181 occurred at DataSocket Read in Read RSS Feed.vi. Possible reason: Protocol not recognized by LabVIEW. Can you please do the following: (1) Figure out how to make this example work! (2) Update your Package Repository to include the repaired, working Exmple. Bob Schor
  9. OK, seems like there's a way to manually install the packages without the VIPM. On my W10 machine the VIPM would not start, so I copied from a W7 VIPM to W10 machine manually. As far as I can tell there are two main directories you'll need to copy: C:\Program Files (x86)\National Instruments\LabVIEW 2018\menus\Categories\JKI Tools This has the MENUS you'll need. Next, there's the VI directory, you may need to open one of the VI's in the package to determine the location of VIs: C:\Program Files (x86)\National Instruments\LabVIEW 2018\vi.lib\addons\_JKI.lib W10 you gotta love it! It's so efficient.
  10. How about this idea? Could I install the package manually? I mean if I install the package I want on another machine, how hard would it be to install/Copy it from one machine to the other? My home PC has LV2018 with W7. Seems W7 doesn't have a problem running VIPM. Thanks! Doug
  11. Another note, my OLD Windows 7 PC is running the latest version of VIPM with no problems, but, the old W7 Machine is running LV2015 and not LV2018. I'm guessing it's a combination of W10 and/or LV2018 preventing VIPM from running correctly.
  12. I started looking around trying to figure out why VIPM wouldn't start. I found the "Vi Package Manager.ini" file: l tried finding the "Settings.ini" file, nowhere on my computer is there a VIPM\Settings.ini file. Could this missing "Settings.ini" be causing the VIPM to not start up?
  13. Are there any links to older versions of VIPM? Still no luck getting the Free Version to work.
  14. I was able to squeeze another error message out from the Desktop. See Attached. I thought this was going to work! My NI PSP Service Locator wasn't started! (See attached) Same results, after I started the NI PSP Service Locator. VIPM, didn't start.
  15. VIPM worked before, but, now it will not start. I have W10 Pro 64BIT, Running Labview 2018 Version 18.0.1f2. If I try to run from my desktop, I see the VIPM Icon briefly, then it disappears. (See attached). I next tried to use the "INSTALL" button from the jki.net website, this time I get an error message. (See Attached). Things I've tried: Run as Administrator Disable Anti-Virus Repair using the VIPM install program. Re-Install. Reboot. This URL: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P9YmSAK&l=en-US Open to try suggestions. Thank you, Doug Vi Package Manager Closes When Launched From Desktop.mp4
  16. Hello! jki_rsc_toolkits_palette- how install on computer without internet?
  17. Here is what I'm currently doing : Is there a better way? xml catch.vi
  18. Here is the content of an XML file that I need to load : I don't know if this is standard XML... In capabilities, "yes" and "no" are options and in currentValue "no" is the selected value. Is there a way, using EasyXML, to read capabilities as an array of string and retrieve "yes" and "no" read currentValue as a string in order to retrieve "no" Thanks in advance
  19. Hi, in our company we changed the Parse State Queue VI, so that we get the previous state in case we had an error. With this it was so much easier to debug the JKI-SM, because we were able to display the state, where the error occurred. Maybe this this an idea for the original Parse State Queue?? Here is an snippet based on the "old" Parse State Queue VI.
  20. Hello, We are recently facing an issue where vip files are not getting opened in VIPM whenever we double click it. It just opens the VIPM but doesn't give a dialog to choose a LabVIEW version and install. I need to go to VIPM and select File>>Open Package File(s) to open a vip file. I have also made VIPM as the default application to open a vip file. Still the same issue. VIPM version: 2018
  21. Hello! jki_rsc_toolkits_palette- how install on computer without internet? Thank you!
  22. Update... It seems this is related to Custom Build Directories, as the same VIPC files deploying to vi.lib behave as expected (Package A contains only testA.vi and Package B only testB.vi). I of course haven't tested other directories in the options tree, but helps isolate.
  23. Hello, I have been doing some testing for a potential deployment, and coming up with unexpected behavior building packages. This might be my basic misunderstanding, but consulting the documentation and the web I am not finding a clear answer. The scenario is this... I create VI Package A, that contains source files. I deploy VI Package A to my development PC to a custom directory (in this case Desktop/Sandbox/DMC/testpkgA). No problem. Later, I decide to build VI Package B. Source files in Package B rely on elements of VI Package A. I am using the Free Edition of VIPM so I cannot auto-scan package dependencies at build time, no problem. I go ahead an manually add a required dependency to Package B (in the VIPC file) pointing to Package A (already installed on the PC). Alright now I am ready to build, cool Package B is built and deploys to Desktop/Sandbox/DMC/testpkgB. Here's where we get the issue, Package B is deploying a copy of the VI referenced in Package A, instead of simply loading that dependency from the package already installed on disk. The result is (2) VIs named testA.vi: one located in testpkgA, and another located in testpkgB. See attached image for the full example, I have also included a snapshot of the files-installed documentation in the VIPM database directory. This seems deliberate, but goes against the concept of packages being independently updated/etc. If for example I later deploy a revision to testpkgA, by source material in testpkgB will either be in conflict or remain unchanged (as it deployed its own code copy that will not received changes). Can anyone comment on this behavior? Or, how I can deploy packages atomically with dependencies By Reference? Thanks, Patrick
  24. It will be helpful if there are examples to learn from. I ran a simple test using GET, but get 401 error: unauthorized, even there is no authorisation required. Thanks
  25. I'm trying to install OpenG Toolkit to LabVIEW 2015 SP1, but it turns out to the package installed is missing all dependencies. I know the latest OpenG Toolkit version is 4.0.1.9, but the only version I can see in VIPM is 1.0.0.5. Please advise how I can install the latest library with all dependencies. Thank you!
  26. I too would be interested in a way to make this work in an automated way. But until then one thing that might help make less steps, is making a VIPC with all the packages you want contained in it. Then on the new machine, after installing all things NI, you can double click that VIPC file, it will open it in VIPM, and ask what version to install them in, and then it installs all the packages at once. It still is a manual process but you don't have to select packages from a list, or be connected to the internet.
  27. Cheers @Jim Kring, lots of challenging problems to solve with LabVIEW 🙂 EasyXML Toolkit is fabulous, I remember there use to be a paid version, it's really nice of JKI to have put it OpenSource on GitHub! If there was a way to donate money to thank the developers, I would!
  28. Hello! I have a minor suggestion for the JKI SM editor - simply the default placement. I believe the text and boxes I added to two screenshots will explain what I mean, and why; in summary, I simply recommend moving the editor widow down and left several pixels so as to not block the VIs minimize-close boxes, the VI's Icon, and part of the VI's slider. Yes, I know you recommend one screen per VI and sliders shouldn't be that important, but some of us are not as clever and efficient coders as JKI folks...;-) Thanks for considering, Randy
  1. Load more activity
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.