Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 11/06/2010 in Posts

  1. 4 points
    It would also be nice to have the shell menu option "Add to VIPM Library." on *.vip files and not only on *.vipc files. This way *.vip files can be added to the VIPM library from the windows explorer without having to install them.
  2. 3 points
    I'd love to see these three License-related improvements to VIPM: 1) First, a main window column showing the package license, so it becomes very easy to see whether a package is open source, freeware, proprietary/custom, or something else. It'd be nice if the column title could be clicked to sort sort packages by license type: 2) To complement this, a change to the filter box with options to filter by license type, or maybe a second filtering box for this specific purpose. This would further help those searching for packages to focus on finding one they can afford and actually use for new open source projects, which is particularly relevant now that LabVIEW Community Edition is going to bring in lots of new users who definitely aren't going to purchase proprietary add-ons: 3) Finally, it be interesting for the VIPM Community Edition, specifically, to only allow the creation of open source packages, what would create a clear barrier to those who might be thinking of using VIPM Community Edition for proprietary package creation. This could be done by changing the "License Agreement Name" (in VIMP Community Edition only) from a free form text field to a combo box listing only OSI-Approved licenses' SPDX codes, therefore making the intended purpose extremely clear. The default option could be BSD, with other popular OSI-Approved licenses listed below it, and less common ones (if requested) on a submenu: What do you think? 😊 PS: Re-posted with changes from the original in the VIPM 2020 Beta board.
  3. 3 points
    I have installed LABVIEW 2019, and I followed the procedures to make sure VIPM can communicate with VIPM 2018.0.0f2: https://support.jki.net/hc/en-us/articles/214135683-Resolving-issues-with-VIPM-connecting-to-LabVIEW But, still I do not see LABVIEW 2019 listed within the VIPM window: Any clue on how o solve this? Thanks
  4. 2 points
    I do not know what I am doing wrong: I have an account on https://www.vipm.io/ where I can log in. I have VIPM installed and it was just recently automatically updated. I am able to install i2 JSON for 2018-64 I am not able to log in for "community" or "free" status. When I choose in the new window "Use existing JKI account" I get an error message, when using the account data for www.vipm.io. I also get an error when choosing "Sing up for a new JKI account". When pressing "Forgot your password?" an new tab in the browser opens where I can write my mail address and it tells me that an email was sent. However, I nether get the mail, nor is it gone to my spam folder. What can I do to solve this. I rely in my largest project on the OpenG lib and the MGI lib, which was not a problem to install in previous time. Best regards Wolfgang Kilian
  5. 2 points
    Hi, I am having an issue with functions palette I generate in VIPM. The palette is generated and behaves correctly in LabVIEW, however, when I click "show in palettes" in VIPM after installing toolkit, instead of my functions palette, Agilent 34401 palette is displayed. Any idea what might be wrong?
  6. 2 points
    Some advanced users are asking for support to install VIPM for Windows onto a Docker container. This would allow creating fully automated build processes that spin up virtual machines that have LabVIEW and VIPM installed on them, so that VI Packages can be created automatically.
  7. 2 points
    In any validation setting, the tolerances around measured and reported values is critical, and so is tracking the tolerances for any given parameter being measured, with any measurement device or sensor. To automate the calculation of these ranges and limits within our overall application, we must track the specifications of any of these parameters. This used to be done using a peer reviewed excel table, and was loaded into LabVIEW using the Report Generation Toolkit. This had several drawbacks, but that's not the point of this post. The point is that using Excel means that any text becomes free text and if data isn't entered correctly then it can cause issues with parsing. So I created something I call the Specification Manager. It's a small utility that is intended to only be used by validation test case developers to add new specifications to the database of available specifications that can be tested, or to add new hardware for use in the validation tool. I built this tool in about 2-3 days as a way of trying out the JKI Flat UI 2.0 and the Design Palette. Here's the home screen of the tool: Some things that I think make this a nice UI: Dark background (76, 76, 76) and a nice pop of vibrant color, the icon for the tool uses the same two colors to provide consistency All native windows elements are hidden as this tool is very small and simple, there's no need for a toolbar, etc. Our company uses Century Gothic as a common font in many places, so I used that for some of my UI elements (title bar, specifically) System Chiselled Line separating workflow components of the tool. That horizontal line doesn't look like much, but it's a visual separation of the two things you're supposed to do with this tool. 1) select a file path, 2) manipulate the individual .spec files Listbox to store data - I hate working with listboxes, but I think they are the best UI element for storing continuous data. They look way better than any array I've seen when the data is simple. To add a new specification to the library, you press 'add' and get a dialog window that's a sort of wizard: I used the JKI built-in buttons here to give some sort of icon to the various specifications that can be created. I also changed the color scheme of this wizard to 'light' to signal to the user that this is a dialog/configuration type window and not really part of the core functionality of the utility. If this were a project for a wider audience, I would have customized them a bit more, but as-is, I think it's okay. The symbols are kind of meaningless as the library isn't as vast as I'd like it to be. After selecting the type of specification, you enter the name of it: This screen continues to use consistent fonts, and buttons from the previous screen. Pressing 'Continue' gets you to the heart of what this application is intended to do, modify specifications. (*I typed in random data, please don't double check these against the actual specifications of the 6218 - I will not be using this data in production) I used an array of customized clusters containing the JKI Flat UI 2.0 numerics and enums, then used some more of their pre-built buttons at the bottom for continued navigation. I used the same pop of color on the cancel button, mostly for fun, but also as a way of drawing immediate contrast between the other two operations that the buttons provide. That's about it! This is an internal-only tool, but I think that editing specifications using this small purpose-built utility will be easier than us using Excel to do the same thing. Overall impressions of the Flat UI 2.0 library: Pros: good selection of commonly used buttons and controls, consistent theme across numerics, strings, enums, file paths, and buttons - makes a consistent UI easy to build Color customization of buttons is easy, including customization of the hover-state (which I did to the 'X' button on the home screen of the utility) Wishlist: As with any library of icons and UI elements - a wider selection. I had a hard time finding icons for my 'Add Specification' wizard screen and had to reach pretty far Design palette only launches when using the left ctrl+shift buttons, it'd be nice for it to work with either left or right Cons: Working with the String controls and indicators was a little strange. There are actually two resizable elements in a single control, one for the frame/background and one for the actual text field. I had to be careful when resizing the control to make sure that both fields were resized correctly. Also the front panel snapping meant that the border around the text area was easy to lose if the text field itself was resized incorrectly. I will probably continue to use the UI library for the internal only developer tools, but for the main applications that I'm working on there is still heavy customization specific to my company that I will continue to have to do. Thanks for reading - feel free to ask any questions about the design choices or other elements of the UI for this tool.
  8. 2 points
    Got same error from time to time. Have to restart LabVIEW. LabVIEW 2019 32bit Windows 7 Pro.
  9. 2 points
    This may be due to the Wayland X server. If you are using Wayland, try switching to the Xorg X server and see if the command works.
  10. 2 points
    For the fact that one could use a 3rd party additional software for $ 499 only one year meaningfully is pure rip-off. JKI, never again !!
  11. 2 points
    In version 1.0.3 we've added System Arrays to the "System" theme of the JKI Design Palette. There are two different System Arrays arrays. 1) There's one with a "System Spin Control" for the Index Display (with increment and decrement buttons), which is nice because it's similar to the other array controls (Classic, etc.) 2) There's another one with a "System Numeric" for the Index Display (without increment and decrement buttons), which is nice because sometimes you don't want/need the increment and decrement buttons. These are really useful for creating nice System themed UIs with controls like the ones shown below. Have fun!
  12. 2 points
    Nice. The empty clusters and arrays now work without issues! Here is a suggestion for the existing clusters/arrays that contain a delete me button (in case you need to keep it after the latest upgrade): why not make the text hidden and the color transparent so it won't even appear (since it is going to be deleted anyway) And for the decorations, I suggest that you put the decoration on top of an transparent empty cluster that will get deleted after being placed on the FP (in a similar approach to the above).
  13. 2 points
    Yeah I was able to replicate the issues that you described. Creating and empty array/cluster caused all the controls to disappear on the palette. That is why the existing clusters in the palette contains a dummy "Delete Me" control :). You can do the same with a decoration to add it to the palette: AA
  14. 2 points
    Show Labels of All Controls in the JKI SDP (Ctrl+L) You can show or hide the labels of all the controls in the JKI SDP by pressing Ctrl+L. Press Ctrl+L to show labels on all the controls: Press Ctrl+L again to hide the labels
  15. 2 points
    Ideas and Features: Add other commonly used controls that aren't supported Clusters, arrays, subpanels, decorations, etc. Add more advanced controls Animated Menu Toggled controls (such as one button that does start + stop function) Custom Radio Selectors (paging/tabbing) Draggable Navbar UI templates Merge VIs Other commonly used modern UI building blocks Let us know if you have any others! Post an Idea or Feature Request Now.
  16. 2 points
    Hello Jim, It used to be that older versions of VIPM could connect to the newest versions of LABVIEW. Is there any particular reason why this changed? This issue seems to have happened from the VIPM 2018 Version because it was a major update. Is this going to happen for all versions of VIPMs in the future? The problem is that I have a licence for VIPM 2018, and now I can't use VIPM 2018 with LABVIEW 2019 (I won't be able to generate VIPC files without the licence). thanks Helcio
  17. 2 points
    Get the JKI State Machine Editor (just check VIPM for package updates) Version 2013.4.0.186 This new release adds a right-click option called "Find Data Accessors" to Bundle by Name and Unbundle by Name nodes in a JKI State Machine. Using this feature will open a dialog showing all the frames of the JKI State Machine that access the data, as shown below:
  18. 2 points
    I found one problem that occurs to me. "Find Data Accessors" is available in any VI (not only JKI State Machine) for the Unbudle by Name function, but its call does not cause the appropriate list to be displayed in the dialog box, although the application is started and consumes processor resources. Calling it several times on a notebook with an i5-4210M processor results in 100% CPU load. I've attached a screenshot for the FMSM example from LabVIEW example projects. As you can see, also Add Dynamic Events and JKI State Machine Editor... are visible - only when pop-up on Bundle/Unbundle by Name.
  19. 1 point
    Hi Jim, That was the setting I knew that exists and didn't find last night (I was probably too tired 😇). Anyway, I gave it a try this morning without success. I got no error, but text wasn't appended to vi description. Any idea ?
  20. 1 point
    It works... Thanks a lot. Best regards Markus
  21. 1 point
    I am having trouble installing VIPackage Manager 2020. I keep getting the following error: Any help would be appreciated.
  22. 1 point
    And it works perfectly now, thanks!
  23. 1 point
    I was trying to apply a vipc using the API and it tells me 20.0 isn't a valid LabVIEW version. Digging into I found this: see attached image. Maybe you guys were a little too optimistic about the switch to NXG and figured wed never see 20.0?
  24. 1 point
    Curious if there is any plan to ad LV2020 support?
  25. 1 point
    Hi Sam. VIPM 2020 works a little bit differently. It hangs around in memory for a little bit in case someone uses it again -- this way, it's much more responsive. Yet, it's changed the observed behavior around exactly when the package list refreshes. This is something we're working on and should be improved in the next release.
  26. 1 point
    We just released a new build with 2020 support https://www.vipm.io/package/jki_design_palette/
  27. 1 point
    Yes, I use the in-line execution mode on all the "constant" VIs that I generate as well. I tried out a quick POC performance test... There doesn't seem to be any real difference when using constants. I also tried the same LUT VI with the in-line execution switched off... that does make a HUGE difference. The in-line version is ~11x faster than the same VI with it turned off, and the VI that only contains a constant gets hit just as hard. Call overhead on such a tiny operation = ouch. I'm thinking the improved maintainability makes the LUT concept a winner. Thanks so much for the suggestion... now to rework my code conversion scripts and delete a lot of VIs I don't need anymore. 😅
  28. 1 point
    This is covered in part in various places but I thought it might be useful to have it in one. I've got VIPM running on CentOS 8 but you have to jump through some hoops due to 64 bit, wayland and rpm signing! 1. Install support for the 32 bit RTE on 64 bit by installing the following packages: glibc.i686 libstdc++.i686 libXinerama.i686 libGL.so.1 2. To install the run time engine - you need to remove the digest checks since these have got more strict. In the run time engine folder edit INSTALL so the line that starts RPMOPT includes --nodigest at the end of the string. 3. Now follow the standard install instructions. 4. Before running VIPM run the command "xhost si:localuser:root" to allow the root user to launch a window process. I believe this is due to wayland. Hope that helps someone!
  29. 1 point
    I was able to fix this by setting vip files to open with VIPM File Handler.exe by default.
  30. 1 point
    I can't get the Design Palette to launch using keyboard shortcuts. I know it used to work, so I'm not sure what's going on. Launching from the Tools menu does still work. I might try removing and reinstalling the Design Palette, but has anyone else run into this?
  31. 1 point
    My welcome screen looks ugly. Why is the font way too large for the allocated space, see picture? (LV 2019, Windows 10)?
  32. 1 point
    Hello JKI Team & Community, I'm having trouble activating the JKI Design Palette, specifically requesting the activation code. Labview throws an Network Time Limit Error when submitting the mail adress (see attached image). The error is consistent within the corporate network (proxy/firewall) and on the unrestricted mobile hotspot. Using Windows 10, Labview 2015 (32bit) Looking forward to trying the new controls, Cheers
  33. 1 point
    That's to protect privacy... But seriously, thanks for letting us know. Font sizings can get a little wonky in LabVIEW. We'll see if we can fix this.
  34. 1 point
    So far it looks like issue is not existing anymore. Thanks
  35. 1 point
    @Jim Kring Just tried it out. I downloaded and installed from the download link from option A, which installed 1.0.0.155 again. Then VIPM said there was an update available which installed 1.0.1.176. I entered my email address and was prompted for an offline activation. The link took me to the form with all of my information pre-filled (nice touch!) and I was able to activate with no issues! All good here now. Thanks for the quick fix
  36. 1 point
    Yes, when the DP shows up as I open a project it is pinned. See attached video : I have a small project already open with the main.vi running Then open a DQMH project >> DP shows up pinned Untitled.mp4
  37. 1 point
    I suspected that but could not pinpoint which one could be causing the issue. I monitored the memory consumption to see if it is spiking during scrolling but it is not. I am not able to scroll all the way in neither classic nor Flat... And out of no where, i am sometimes getting the error below (even when the design palette is not open). I guess the palette continuously check for communication with the server in the background for some reason. Ali
  38. 1 point
    Hello JKI, I found two issues on your recent release of JKI Flat UI controls V2.0. Those details are follows, 1. When I changing to true state on settings control, it shows different image instead of settings image. 2. When I try to enter values on numeric controls, the cursor hover expending beyond that control size. Typically, the cursor hover size would be within the numeric control size. I hope, these information's may help to improve changes on your Flat UI controls V2.0 Regards, SABARI SARAVANAN M
  39. 1 point
    Never mind. It appears my JKI state machine was a older version after the upgrade I was able to access explorer option.
  40. 1 point
    Hi Helcio, Yes, you will need to use VIPM 2019 in order to manage LabVIEW 2019. You can upgrade via the menu in VIPM (Help >> Check for VIPM Updates) or download from vipm.jki.net/download -Jim
  41. 1 point
    Hello everyone, Fist of all thank you for your Tools that are very helpfull. I'm trying to use the HTTP JKI REST drivers with an HTTPS website but I need to go trough a Proxy. How is it possible to desribe the PROXY settings with this driver? Thank you by advance.
  42. 1 point
    single step sounds good - and should work in both direction Last/Next Step dynamic state generation - maybe JSON imported State"Objects" (export fct would be nice 2)
  43. 1 point
    I had a separate QD plugin for this, but I can't find evidence that I ever shared it with the community. You've just given "ctrl+space ctrl+q" back to me. Thank you. However, mine puts it exactly eight pixels from the output tunnel and pre-wires an empty String constant... Another feature to add might be my JKI State Machine Follower. It activates the current Case Structure case while the VI is running. Maybe? You'll save me "ctrl+space ctrl+f"... Thanks for all your work on this, Jim
  44. 1 point
    @Robert Smith I know this is four years later and probably not very helpful, but I just used VI Tester for the first time and found that my tests would not appear in the UI if the test classes were in auto-populating folders. This may have been your problem. Hopefully this helps someone else who might come across this thread.
  45. 1 point
    It would be great if there is a preview window along with the description editor. Right now, after formatting the description with various tags (like bold/italics etc.,) I would need to build the package in order to see the formatting. If there is a preview pane along with the description, it would easy to see the final formatting. Thanks, Ajay.
  46. 1 point
    Yep, the new version works well. Many thanks!
  47. 1 point
    The issue is because I renamed the event case to "Idle" from "" (empty string). Renaming the case name will resolve this issue.
  48. 1 point
    I've been tasked with trying to build packages on MacOS, but so far I have not been able to successfully build anything. The builds complete without error, but when I try to open the packages I just built they do not contain any files. I'm running MacOS High Sierra which is not explicitly supported by any version of LabVIEW at the moment, but I'm using LabVIEW 2016. Has anyone successfully built packages on High Sierra?
  49. 1 point
    Yes I can see the JKI packages. I noticed there appears to now be a "MacOS JKI VI Tester" package
  50. 1 point
    Yes, were in the process of making some design decisions -- I'm also in Roma for the CLA Summit and am presenting tomorrow... One thing that we're evaluating is the impact of changing the process VI to be Dynamic Dispatch (with the ability to call or override the parent). This changes slightly the mechanics of process registration and synchronization. Additionally, we're working on a full scripting API to allow programmatic creating, editing, and inspection of JKI SMO classes. This aims to enable creating user interface tools that simplify development. We've been doing this experimental development outside of GitHub to avoid a lot of noise. I'd be happy to loop you into what we're working toward and some of the open design questions.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.