Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 07/03/2019 in Posts

  1. 4 points
    It would also be nice to have the shell menu option "Add to VIPM Library." on *.vip files and not only on *.vipc files. This way *.vip files can be added to the VIPM library from the windows explorer without having to install them.
  2. 3 points
    I'd love to see these three License-related improvements to VIPM: 1) First, a main window column showing the package license, so it becomes very easy to see whether a package is open source, freeware, proprietary/custom, or something else. It'd be nice if the column title could be clicked to sort sort packages by license type: 2) To complement this, a change to the filter box with options to filter by license type, or maybe a second filtering box for this specific purpose. This would further help those searching for packages to focus on finding one they can afford and actually use for new open source projects, which is particularly relevant now that LabVIEW Community Edition is going to bring in lots of new users who definitely aren't going to purchase proprietary add-ons: 3) Finally, it be interesting for the VIPM Community Edition, specifically, to only allow the creation of open source packages, what would create a clear barrier to those who might be thinking of using VIPM Community Edition for proprietary package creation. This could be done by changing the "License Agreement Name" (in VIMP Community Edition only) from a free form text field to a combo box listing only OSI-Approved licenses' SPDX codes, therefore making the intended purpose extremely clear. The default option could be BSD, with other popular OSI-Approved licenses listed below it, and less common ones (if requested) on a submenu: What do you think? 😊 PS: Re-posted with changes from the original in the VIPM 2020 Beta board.
  3. 2 points
    I do not know what I am doing wrong: I have an account on https://www.vipm.io/ where I can log in. I have VIPM installed and it was just recently automatically updated. I am able to install i2 JSON for 2018-64 I am not able to log in for "community" or "free" status. When I choose in the new window "Use existing JKI account" I get an error message, when using the account data for www.vipm.io. I also get an error when choosing "Sing up for a new JKI account". When pressing "Forgot your password?" an new tab in the browser opens where I can write my mail address and it tells me that an email was sent. However, I nether get the mail, nor is it gone to my spam folder. What can I do to solve this. I rely in my largest project on the OpenG lib and the MGI lib, which was not a problem to install in previous time. Best regards Wolfgang Kilian
  4. 2 points
    Some advanced users are asking for support to install VIPM for Windows onto a Docker container. This would allow creating fully automated build processes that spin up virtual machines that have LabVIEW and VIPM installed on them, so that VI Packages can be created automatically.
  5. 2 points
    In any validation setting, the tolerances around measured and reported values is critical, and so is tracking the tolerances for any given parameter being measured, with any measurement device or sensor. To automate the calculation of these ranges and limits within our overall application, we must track the specifications of any of these parameters. This used to be done using a peer reviewed excel table, and was loaded into LabVIEW using the Report Generation Toolkit. This had several drawbacks, but that's not the point of this post. The point is that using Excel means that any text becomes free text and if data isn't entered correctly then it can cause issues with parsing. So I created something I call the Specification Manager. It's a small utility that is intended to only be used by validation test case developers to add new specifications to the database of available specifications that can be tested, or to add new hardware for use in the validation tool. I built this tool in about 2-3 days as a way of trying out the JKI Flat UI 2.0 and the Design Palette. Here's the home screen of the tool: Some things that I think make this a nice UI: Dark background (76, 76, 76) and a nice pop of vibrant color, the icon for the tool uses the same two colors to provide consistency All native windows elements are hidden as this tool is very small and simple, there's no need for a toolbar, etc. Our company uses Century Gothic as a common font in many places, so I used that for some of my UI elements (title bar, specifically) System Chiselled Line separating workflow components of the tool. That horizontal line doesn't look like much, but it's a visual separation of the two things you're supposed to do with this tool. 1) select a file path, 2) manipulate the individual .spec files Listbox to store data - I hate working with listboxes, but I think they are the best UI element for storing continuous data. They look way better than any array I've seen when the data is simple. To add a new specification to the library, you press 'add' and get a dialog window that's a sort of wizard: I used the JKI built-in buttons here to give some sort of icon to the various specifications that can be created. I also changed the color scheme of this wizard to 'light' to signal to the user that this is a dialog/configuration type window and not really part of the core functionality of the utility. If this were a project for a wider audience, I would have customized them a bit more, but as-is, I think it's okay. The symbols are kind of meaningless as the library isn't as vast as I'd like it to be. After selecting the type of specification, you enter the name of it: This screen continues to use consistent fonts, and buttons from the previous screen. Pressing 'Continue' gets you to the heart of what this application is intended to do, modify specifications. (*I typed in random data, please don't double check these against the actual specifications of the 6218 - I will not be using this data in production) I used an array of customized clusters containing the JKI Flat UI 2.0 numerics and enums, then used some more of their pre-built buttons at the bottom for continued navigation. I used the same pop of color on the cancel button, mostly for fun, but also as a way of drawing immediate contrast between the other two operations that the buttons provide. That's about it! This is an internal-only tool, but I think that editing specifications using this small purpose-built utility will be easier than us using Excel to do the same thing. Overall impressions of the Flat UI 2.0 library: Pros: good selection of commonly used buttons and controls, consistent theme across numerics, strings, enums, file paths, and buttons - makes a consistent UI easy to build Color customization of buttons is easy, including customization of the hover-state (which I did to the 'X' button on the home screen of the utility) Wishlist: As with any library of icons and UI elements - a wider selection. I had a hard time finding icons for my 'Add Specification' wizard screen and had to reach pretty far Design palette only launches when using the left ctrl+shift buttons, it'd be nice for it to work with either left or right Cons: Working with the String controls and indicators was a little strange. There are actually two resizable elements in a single control, one for the frame/background and one for the actual text field. I had to be careful when resizing the control to make sure that both fields were resized correctly. Also the front panel snapping meant that the border around the text area was easy to lose if the text field itself was resized incorrectly. I will probably continue to use the UI library for the internal only developer tools, but for the main applications that I'm working on there is still heavy customization specific to my company that I will continue to have to do. Thanks for reading - feel free to ask any questions about the design choices or other elements of the UI for this tool.
  6. 2 points
    Got same error from time to time. Have to restart LabVIEW. LabVIEW 2019 32bit Windows 7 Pro.
  7. 2 points
    This may be due to the Wayland X server. If you are using Wayland, try switching to the Xorg X server and see if the command works.
  8. 2 points
    I have installed LABVIEW 2019, and I followed the procedures to make sure VIPM can communicate with VIPM 2018.0.0f2: https://support.jki.net/hc/en-us/articles/214135683-Resolving-issues-with-VIPM-connecting-to-LabVIEW But, still I do not see LABVIEW 2019 listed within the VIPM window: Any clue on how o solve this? Thanks
  9. 2 points
    For the fact that one could use a 3rd party additional software for $ 499 only one year meaningfully is pure rip-off. JKI, never again !!
  10. 2 points
    In version 1.0.3 we've added System Arrays to the "System" theme of the JKI Design Palette. There are two different System Arrays arrays. 1) There's one with a "System Spin Control" for the Index Display (with increment and decrement buttons), which is nice because it's similar to the other array controls (Classic, etc.) 2) There's another one with a "System Numeric" for the Index Display (without increment and decrement buttons), which is nice because sometimes you don't want/need the increment and decrement buttons. These are really useful for creating nice System themed UIs with controls like the ones shown below. Have fun!
  11. 2 points
    Nice. The empty clusters and arrays now work without issues! Here is a suggestion for the existing clusters/arrays that contain a delete me button (in case you need to keep it after the latest upgrade): why not make the text hidden and the color transparent so it won't even appear (since it is going to be deleted anyway) And for the decorations, I suggest that you put the decoration on top of an transparent empty cluster that will get deleted after being placed on the FP (in a similar approach to the above).
  12. 2 points
    Yeah I was able to replicate the issues that you described. Creating and empty array/cluster caused all the controls to disappear on the palette. That is why the existing clusters in the palette contains a dummy "Delete Me" control :). You can do the same with a decoration to add it to the palette: AA
  13. 2 points
    Show Labels of All Controls in the JKI SDP (Ctrl+L) You can show or hide the labels of all the controls in the JKI SDP by pressing Ctrl+L. Press Ctrl+L to show labels on all the controls: Press Ctrl+L again to hide the labels
  14. 2 points
    Ideas and Features: Add other commonly used controls that aren't supported Clusters, arrays, subpanels, decorations, etc. Add more advanced controls Animated Menu Toggled controls (such as one button that does start + stop function) Custom Radio Selectors (paging/tabbing) Draggable Navbar UI templates Merge VIs Other commonly used modern UI building blocks Let us know if you have any others! Post an Idea or Feature Request Now.
  15. 2 points
    Hello Jim, It used to be that older versions of VIPM could connect to the newest versions of LABVIEW. Is there any particular reason why this changed? This issue seems to have happened from the VIPM 2018 Version because it was a major update. Is this going to happen for all versions of VIPMs in the future? The problem is that I have a licence for VIPM 2018, and now I can't use VIPM 2018 with LABVIEW 2019 (I won't be able to generate VIPC files without the licence). thanks Helcio
  16. 1 point
    I am having trouble installing VIPackage Manager 2020. I keep getting the following error: Any help would be appreciated.
  17. 1 point
    Hi, This is not a problem report but more a success story. Well done crew! I heard about caraya when I looked through the talks of VI Week (and I'm still watching videos) and I wanted to give it a go. I've been wanting to try unit testing for a while but the built-in stuff just wasn't doing it for me. We (work) do all our building, releasing and deployment via Azure pipelines so when I heard that caraya can generate JUnit format test results, I jumped straight in and made myself a test pipeline for a new feature we just added to one of our libraries. I downloaded the TDD template, copied the Pre-Build-Action.vi into my project (it needed a bit of fixing) and defined some tests. Once I had the pre-build vi working I looked at the Azure part. I wanted the pipeline to be aware of the test results. All I had to do is to call the Publish Test Results task which takes the results and publishes them to the Azure test repository and bang! Unit testing done. Here are some screenshots And then I added a broken test
  18. 1 point
    Curious if there is any plan to ad LV2020 support?
  19. 1 point
    Yes! Thanks for the ping about this Sam. We will update this, very soon.
  20. 1 point
    John, check out "Test Runner Pre-build action.vi" in the 1.0 release. I'm not sure what the current version is on LVTN, but you can find 1.0 on GitHub: https://github.com/JKISoftware/Caraya/tree/release/1.0.0/src The first snippet below is the Pre-Build action itself, the second is the actual guts of where the test gets invoked. Let me know if that doesn't get you started in the right direction or you have more questions.
  21. 1 point
    Is this going to be in the next VIPM version?
  22. 1 point
    Hey Ruslan, Thanks - I was able to take that dialog window out of my project pretty easily. Not sure what version of LabVIEW you're using, so I saved it back for 2013 just in case. The one dialog window is effectively two clusters stacked on top of each other. First I make the selection cluster visible, then when a user selects which option they want, I hide that cluster and the Name and Apply buttons are visible beneath it. Happy to answer any questions you've got on it. -Nate Add New Specification.vi
  23. 1 point
    Hi In the VIPM 2020 beta I tried to install the error logger from CPE. And indeed that worked except that the include ppl was not correct for LV2019 or LV2018 so not useable. I have send a request to CPE to add those versions but only this morning so somewhat early to expect a reaction. Is it possible to check for ppl versions or should we leave that to the developer.
  24. 1 point
    I try to use the toolkit when it does not crash 😉 and enjoy it a lot, but I've just found that there is no buttons with icons for such often used actions as Read, Write, Send, Receive. Also, there could be more "specialized", like Query, Execute, Init, DeInit, etc. Are there plans to expand the toolkit, or there is some specific reasons why those (at least more common Read/Write, etc.) are not implemented in the toolkit? Thanks a lot, Sincerely, Ivan.
  25. 1 point
    I've been using VIPM for years to access the LabVIEW Tools Network. Recently, one of my machines was set up with a User Account (where I do most of my work) and a separate Admin account. A while ago, I tried to install EasyXML and got a strange error (among other things, I was told the package was not compatible with my OS nor any version of LabVIEW installed on my computer). Turns out the "fix" was to run VIPM from my Admin account. But do I learn? No, months later, I try to install another package. Similar error. While browsing this Forum, I run across my previous note and see "Run VIPM as Administrator", which (are you surprised?) fixes this "new" error. You'd think I would have learned my lesson, but I can at least pass on this warning. Bob Schor
  26. 1 point
    Hey Sam. This should be fixed in VIPM 2020. If you're interested in helping beta test it, please sign up for the LabVIEW 2020 beta.
  27. 1 point
    Let me share the following please - button "Settings" does not have picture in the pressed state. Thanks a lot, Sincerely, kosist.
  28. 1 point
    I hope for you that others which bought VIPM in 2018 see it the same like you. I bet they don't!!!! 🤣😆 I bet NI is also not amused, if people stay with LV2018 for ever. But hey! I don't care anymore, i found a work around.
  29. 1 point
    Thanks for reporting this, Antoine. We just released 1.0.4.193 and it should be available in VIPM shortly.
  30. 1 point
    Well, that is not good!!!😠 In this case, a free update for those who paid for VIPM PRO would only be fair!!!
  31. 1 point
    Use case : When working / debugging on a PreBuild or PostBuild action VI, I sometime keep the Pre/Post Build VI' FP & BD open for debugging in the context in which it was opened by LabVIEW when the build was started (NI.LV.MxLvProvider context instead of the usual main application context that you can see at the bottom left corner of the VI windows). When I am in this context, if I open the JDP, try to drag a control onto the front panel of the VI that is in the NI.LV.MxLvProvider context it doesn't work The work-around is to drag the control into another VI in the main app context, cut it and past it on the VI in the other context Not a big problem because I rarely do UI in that context but thought I'd mention it anyway. See video : feedback JDP.mp4
  32. 1 point
  33. 1 point
    Thanks for testing and letting us know. Yes, we now officially support "empty" clusters and arrays -- previously, these were throwing errors when we tried to load them, but we fixed it so that they are handled better and officially supported. Have fun.
  34. 1 point
    You're really making me think harder now about my cons and wishlists! Thanks to you and the team for the continued refinement of the tool!
  35. 1 point
    Local configuration, FYI: Windows 10 font scaling is at 100% LabVIEW fonts are all defined as "tahoma 13" in ini.
  36. 1 point
    That's to protect privacy... But seriously, thanks for letting us know. Font sizings can get a little wonky in LabVIEW. We'll see if we can fix this.
  37. 1 point
    I think I might be able to share this specific utility I'm working on. It's a very small piece in the big picture of what I'm working on, and I use little utilities like this to try out new toolkits, modules, or LabVIEW components to see what might be worth bringing into our more mainstream code. In this case, the utility I'm working on is an accuracy specification management tool. I can probably post a few screenshots and thoughts on the UI development once I finish it up.
  38. 1 point
    Another minor thing, the button behaves differently from the buttons in the built in path controls. Clicking the button will always trigger the file dialog prompt, versus the other buttons which won't open the dialog if the Mouse Up doesn't happen on the button. Update: Fixed file posted below:
  39. 1 point
    First of all: Thanks for another great LabVIEW tool - highly appreciated! It seems that the ports you are using to activate the design palette and/or download the content is blocked by our corporate network. Using my private internet I could activate it properly, but back again in the company network I get an error message again when I am starting the palette the first time. Would it be possible for you to use other, usually open ports? Or at least let us know which ports need to be opened?! Is there any plan when we can expect the palette for the 64 bit version of LabVIEW? Thanks, Ingo
  40. 1 point
    @Jim Kring Just tried it out. I downloaded and installed from the download link from option A, which installed 1.0.0.155 again. Then VIPM said there was an update available which installed 1.0.1.176. I entered my email address and was prompted for an offline activation. The link took me to the form with all of my information pre-filled (nice touch!) and I was able to activate with no issues! All good here now. Thanks for the quick fix
  41. 1 point
    Hi all, I am having problems with running the JKI Design Pallet. I am getting this error when I sign in. Followed by Has anyone solved this problem with the sign in? I have JKI Flat UI Control 1.0 installed. Any help will be appreciated. Many Thanks
  42. 1 point
    DP.mp4 it also shows up at unexpected moments, e.g when doing a save all from the lvproj window see video
  43. 1 point
    I'm having the same issue, looking forward to a fix.
  44. 1 point
    I suspected that but could not pinpoint which one could be causing the issue. I monitored the memory consumption to see if it is spiking during scrolling but it is not. I am not able to scroll all the way in neither classic nor Flat... And out of no where, i am sometimes getting the error below (even when the design palette is not open). I guess the palette continuously check for communication with the server in the background for some reason. Ali
  45. 1 point
    Dear JKI Team, unfortunately the VIPM could not download the JKI Design Palette from the remote server. No problems with other packages. Kind regards from Germany and thanks for your really great tools! Peter
  46. 1 point
    Hello JKI, I found two issues on your recent release of JKI Flat UI controls V2.0. Those details are follows, 1. When I changing to true state on settings control, it shows different image instead of settings image. 2. When I try to enter values on numeric controls, the cursor hover expending beyond that control size. Typically, the cursor hover size would be within the numeric control size. I hope, these information's may help to improve changes on your Flat UI controls V2.0 Regards, SABARI SARAVANAN M
  47. 1 point
    Can i Link this case structure viewer to my existing case structure. i already created one VI using Enum based state machine.Now i want to convert it to JKI state machine.is there any possibility to convert with minimum changes instead of re-implementing.
  48. 1 point
    Hi JKI team, Firstly I want to thank you for generating the REST toolkit for LabVIEW, it seems pretty easy to connect the IoT cloud. I do, have some glitches when using it. I came across to this youtube demo ( Are you able to make an example to show how to use the tool? If that takes a while, would you please comment on 1. What's the input of Base URL? I used "api.favoriot.com" in my case. 2. Do you define the apiKey in one of the Default Headers? I did this but didn't seem to get anywhere. Your help is appreciated.
  49. 1 point
    It would be nice if we could re-install a specific package. I had some crosslinking between 8.6 and 8.5 (my fault) so I wanted to revert a package. This couldn't be done, so I had to install an older version of the package and sequentially install the newest version. Ton
  50. 1 point
    Hi Ton, That's a great idea -- we've noticed that we need that feature, too. It's on our roadmap. Thanks, -Jim
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.