Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 01/31/2019 in all areas

  1. 2 points
    Nice. The empty clusters and arrays now work without issues! Here is a suggestion for the existing clusters/arrays that contain a delete me button (in case you need to keep it after the latest upgrade): why not make the text hidden and the color transparent so it won't even appear (since it is going to be deleted anyway) And for the decorations, I suggest that you put the decoration on top of an transparent empty cluster that will get deleted after being placed on the FP (in a similar approach to the above).
  2. 2 points
    Yeah I was able to replicate the issues that you described. Creating and empty array/cluster caused all the controls to disappear on the palette. That is why the existing clusters in the palette contains a dummy "Delete Me" control :). You can do the same with a decoration to add it to the palette: AA
  3. 2 points
    Ideas and Features: Add other commonly used controls that aren't supported Clusters, arrays, subpanels, decorations, etc. Add more advanced controls Animated Menu Toggled controls (such as one button that does start + stop function) Custom Radio Selectors (paging/tabbing) Draggable Navbar UI templates Merge VIs Other commonly used modern UI building blocks Let us know if you have any others! Post an Idea or Feature Request Now.
  4. 1 point
    Hi not sure if I'm misunderstanding but what's the use of "I want different colors" and "allow interaction" ? I don't see any different behavior when clicking on the UIs in "interactive" and non-interactive mode (colors do work). I also don't understand the colors, when dragging a UI to a FP (with different color) it changes back to default colors on the FP. Also "Allow interaction" - checkbox and left color box collide (see picture). Last but not least: how do you exit interactive and color mode? I had to restart LabVIEW. Regards Christioh
  5. 1 point
    Hi all, First, thank you JKI for your great tool that makes the design of my UIs so much easier! I successfully added my own themes and controls to the JKI Design Palette but I noticed some controls are not supported. Arrays and clusters with no elements: data structures like arrays and clusters require to have elements to be added to the Palette. Adding arrays or clusters that don't have elements make all the controls in the JKI Design Palette disappear as shown below. In the future, I think it would be great to be able to add our own arrays and clusters that don't have a type to the Palette. Decorations: decorations can't be added to the Palette. I tried to add my own decorations to the Palette and it looks like they are not supported. It didn't make the other controls disappear like above but I think it would be a great improvement to have access to decorations (classic or our own) via the JKI Design Palette. Best, Benoit
  6. 1 point
    My welcome screen looks ugly. Why is the font way too large for the allocated space, see picture? (LV 2019, Windows 10)?
  7. 1 point
    Looks like the newest version fixed it. Thanks!
  8. 1 point
    Thanks for testing and letting us know. Yes, we now officially support "empty" clusters and arrays -- previously, these were throwing errors when we tried to load them, but we fixed it so that they are handled better and officially supported. Have fun.
  9. 1 point
    Hi Jim, I just checked and it works great! Good idea to automatically delete the "Delete Me" element once the control is placed on the Front Panel. It also looks like the issue with the controls disappearing doesn't exist anymore. Thanks
  10. 1 point
    In any validation setting, the tolerances around measured and reported values is critical, and so is tracking the tolerances for any given parameter being measured, with any measurement device or sensor. To automate the calculation of these ranges and limits within our overall application, we must track the specifications of any of these parameters. This used to be done using a peer reviewed excel table, and was loaded into LabVIEW using the Report Generation Toolkit. This had several drawbacks, but that's not the point of this post. The point is that using Excel means that any text becomes free text and if data isn't entered correctly then it can cause issues with parsing. So I created something I call the Specification Manager. It's a small utility that is intended to only be used by validation test case developers to add new specifications to the database of available specifications that can be tested, or to add new hardware for use in the validation tool. I built this tool in about 2-3 days as a way of trying out the JKI Flat UI 2.0 and the Design Palette. Here's the home screen of the tool: Some things that I think make this a nice UI: Dark background (76, 76, 76) and a nice pop of vibrant color, the icon for the tool uses the same two colors to provide consistency All native windows elements are hidden as this tool is very small and simple, there's no need for a toolbar, etc. Our company uses Century Gothic as a common font in many places, so I used that for some of my UI elements (title bar, specifically) System Chiselled Line separating workflow components of the tool. That horizontal line doesn't look like much, but it's a visual separation of the two things you're supposed to do with this tool. 1) select a file path, 2) manipulate the individual .spec files Listbox to store data - I hate working with listboxes, but I think they are the best UI element for storing continuous data. They look way better than any array I've seen when the data is simple. To add a new specification to the library, you press 'add' and get a dialog window that's a sort of wizard: I used the JKI built-in buttons here to give some sort of icon to the various specifications that can be created. I also changed the color scheme of this wizard to 'light' to signal to the user that this is a dialog/configuration type window and not really part of the core functionality of the utility. If this were a project for a wider audience, I would have customized them a bit more, but as-is, I think it's okay. The symbols are kind of meaningless as the library isn't as vast as I'd like it to be. After selecting the type of specification, you enter the name of it: This screen continues to use consistent fonts, and buttons from the previous screen. Pressing 'Continue' gets you to the heart of what this application is intended to do, modify specifications. (*I typed in random data, please don't double check these against the actual specifications of the 6218 - I will not be using this data in production) I used an array of customized clusters containing the JKI Flat UI 2.0 numerics and enums, then used some more of their pre-built buttons at the bottom for continued navigation. I used the same pop of color on the cancel button, mostly for fun, but also as a way of drawing immediate contrast between the other two operations that the buttons provide. That's about it! This is an internal-only tool, but I think that editing specifications using this small purpose-built utility will be easier than us using Excel to do the same thing. Overall impressions of the Flat UI 2.0 library: Pros: good selection of commonly used buttons and controls, consistent theme across numerics, strings, enums, file paths, and buttons - makes a consistent UI easy to build Color customization of buttons is easy, including customization of the hover-state (which I did to the 'X' button on the home screen of the utility) Wishlist: As with any library of icons and UI elements - a wider selection. I had a hard time finding icons for my 'Add Specification' wizard screen and had to reach pretty far Design palette only launches when using the left ctrl+shift buttons, it'd be nice for it to work with either left or right Cons: Working with the String controls and indicators was a little strange. There are actually two resizable elements in a single control, one for the frame/background and one for the actual text field. I had to be careful when resizing the control to make sure that both fields were resized correctly. Also the front panel snapping meant that the border around the text area was easy to lose if the text field itself was resized incorrectly. I will probably continue to use the UI library for the internal only developer tools, but for the main applications that I'm working on there is still heavy customization specific to my company that I will continue to have to do. Thanks for reading - feel free to ask any questions about the design choices or other elements of the UI for this tool.
  11. 1 point
    You're really making me think harder now about my cons and wishlists! Thanks to you and the team for the continued refinement of the tool!
  12. 1 point
    The design palette seems to work well for Boolean buttons, but is more difficult to use for other controls. For example, if I type "graph" I get firstly various buttons, then a number of graphs, but there's no way to tell what type of graph: waveform, XY, Intensity - even a chart gets shown here (because the filename on disk includes the word "Graph"). Suggested enhancements: text showing the name of the control currently selected (or under the pointer) in the same way as the LV Control menus the list of control types filtered to show only those which are part of the current search (same as the sizes are only those relevant) where the search text is a standard control type, then those are shown first before buttons that also match the text - and/or ability to sort by type rather than theme a list of other words relevant to the current search that can quickly be clicked on to limit the options shown, either sorted alphabetically or by frequency of use
  13. 1 point
    Hello JKI Team & Community, I'm having trouble activating the JKI Design Palette, specifically requesting the activation code. Labview throws an Network Time Limit Error when submitting the mail adress (see attached image). The error is consistent within the corporate network (proxy/firewall) and on the unrestricted mobile hotspot. Using Windows 10, Labview 2015 (32bit) Looking forward to trying the new controls, Cheers
  14. 1 point
    Local configuration, FYI: Windows 10 font scaling is at 100% LabVIEW fonts are all defined as "tahoma 13" in ini.
  15. 1 point
    That's to protect privacy... But seriously, thanks for letting us know. Font sizings can get a little wonky in LabVIEW. We'll see if we can fix this.
  16. 1 point
    I have a type def'd enum (not strict) and I want to change the style of it from classic to the JKI Flat one for my UI. Using a quick drop shortcut, I can easily change from system, to NXG, to classic, etc. The JKI flat controls don't show up in quick drop (as far as I can tell?) so I can't use the ctrl+p shortcut to replace it. I can use the right-click menu and navigate to where the control is on disk and replace it that way, but then it loses all of the items in the enumeration. Is there any way to support the same quick drop replacement shortcut to maintain enum items? (I know that I can use the Item Names property to recreate the enum, and that's what I did for my application, but it would be nice to have the same functionality for the Flat UI controls.)
  17. 1 point
    Ah - yep, that worked! I usually try and keep my styles separate from the data types, rather than have my type defs styled a certain way, too. But I think for the convenience of not having to recreate my enum and still have it linked to the typedef then this is worth it. Thanks again Jim Edit: I opened my classic enum typdef, replaced it with the jki one, then to avoid replacing all instances of the type def with the JKI one, I went back to my front panel that I wanted to change, used the quick drop shortcut ctrl + p and selected my typedef. That replaced just the instances with the JKI enum, then I went back to my typedef and reverted it to the boring classic style.
  18. 1 point
    Ah, I got it... See if this works -- I just tried it on my computer and I think it does... 1) Open your type definition in the control editor (right click on it and choose Open Type Def.) 2) In the control editor, select the enum... 3) Follow steps #1-4 in my previous post. 4) Save+close the type definition Does that do it?
  19. 1 point
    Story of my life when dealing with LabVIEW UI elements... Thanks for the explanation - I'll keep that in mind when placing buttons on my UI. I tend to put icon-only buttons in the horizontal mode for space saving, or I'll put the text underneath an icon similar to the ribbon in Microsoft Applications, or the left-bar in their newer applications (Teams). Combination of icon and text center aligned in a Laid Out Horizontally layout, and stacked vertically in the same space: Icons and Text all center aligned: Of course, this all heavily depends on how the user plans on interacting with the UI. In my case, the applications I'm working on a very document centric and have lots of configurations and menus, similar to Office applications. To keep the layout familiar to the user, I mimicked the Ribbon and File Menu ideas. Thanks for being so receptive to the feedback. I can tell just how much painstaking pixel pushing work went into these UI elements and am really loving the look and feel (and built-in color customization!) of the new controls.
  20. 1 point
  21. 1 point
    I get this error when trying to submit feedback from the Design Palette: Could be related to me having to do an offline activation?
  22. 1 point
    To pair with the 'Save' and 'Save As' buttons, it'd be nice to have built-in buttons for other common file operations. Take the File menu from Windows 10 Wordpad as an example. The ones missing from this would be 'New', 'Load', 'Email', and 'Exit'.
  23. 1 point
    A mouse over hover effect has become standard in most major software UIs. This effect allows users to interact with controls in a more intuitive way and gives users confidence that they are making the selection that they intend. However there is a long standing NI bug that renders the hover effect inconsistent (see the discussion here: https://forums.ni.com/t5/LabVIEW/Button-Boolean-mouse-hover-not-working-on-64-Bit-LabVIEW/m-p/3944252#M1121887) Until NI makes a fix one 'solution' that I will employ is to disable the hover effect with the controls that I am using so that users do not get confused by a control stuck in a hover state.
  24. 1 point
    I'm using Open AF Method plugin and today when I installed Design Palette with Flat UI 2.0 I noticed that whenever I click on Open Method.. popup menu option, Design Palette gets opened too. It's annoying to close it every time I go from "Send message" vi to the method. Cheers, Patryk
  25. 1 point
    So far it looks like issue is not existing anymore. Thanks
  26. 1 point
    Yes, I meant Quick Drop, but couldn't remember its proper name. I'm using the latest version of JKI Design Palette. However, the problem disappeared. It seems that it disappeared after I first tried Ctrl+Alt+Space to pop up the Design Palette. After that Ctrl+Space correctly opens Quick Drop window.
  27. 1 point
    An easy way to do a super simple resizeable UI, I think, is to use splitter bars and then choose one pane that has some kind of big UI element that is easy to resize like a graph that you can just set as "size to pane". Then set the sticking of the splitter bars so that one pane is the only one that changes size on panel resize events and all others stay the same. Then you don't have to worry about scaling all the little buttons and dealing with decorations getting pixelated. But for a tab control, yeah there is no easy way sadly (at least that I know of). For this, I usually just use radio buttons as the tabs and then a subpanel and switch out which VI is displayed in the subpanel based on the radio buttons.
  28. 1 point
    I am having difficulty creating a UI that scales well for monitors of different resolutions. For programs that have numerous indicators and controls the scaling issue can be especially challenging. The solution provided by NI to this issues as I have read it is to use splitter bars https://forums.ni.com/t5/LabVIEW/Different-Screen-Resolutions-What-is-the-best-method/td-p/1749514 By using splitter bars you can get front panel objects to 'scale' within their pane by first grouping the controls/indicators and then right clicking the group and selecting 'scale object with pane' (although the controls often look distorted when scaling). However, this solution is only viable if you have a limited number of front panel items. When I have too many objects to be displayed on a single window I use tab controls to organize my front panel items. However, you can not use splitter bars within a tab control to so the objects placed on the tab control pages won't scale. https://forums.ni.com/t5/LabVIEW-Idea-Exchange/Tab-Controls-with-Splitter-Bars/idi-p/990693 Are there any other viable solutions that people are using to solve this issue? Does it require sub panels? Are there any best practices?
  29. 1 point
    I knew there should be an alternative 🤓
  30. 1 point
    Show Labels of All Controls in the JKI SDP (Ctrl+L) You can show or hide the labels of all the controls in the JKI SDP by pressing Ctrl+L. Press Ctrl+L to show labels on all the controls: Press Ctrl+L again to hide the labels
  31. 1 point
    First of all: Thanks for another great LabVIEW tool - highly appreciated! It seems that the ports you are using to activate the design palette and/or download the content is blocked by our corporate network. Using my private internet I could activate it properly, but back again in the company network I get an error message again when I am starting the palette the first time. Would it be possible for you to use other, usually open ports? Or at least let us know which ports need to be opened?! Is there any plan when we can expect the palette for the 64 bit version of LabVIEW? Thanks, Ingo
  32. 1 point
    @Jim Kring Just tried it out. I downloaded and installed from the download link from option A, which installed 1.0.0.155 again. Then VIPM said there was an update available which installed 1.0.1.176. I entered my email address and was prompted for an offline activation. The link took me to the form with all of my information pre-filled (nice touch!) and I was able to activate with no issues! All good here now. Thanks for the quick fix
  33. 1 point
    Hi Jim, thank you the error has gone.
  34. 1 point
    The design palette shows up every time I open a LabVIEW project, is it the intended behavior? And is it possible to change this? Cheers
  35. 1 point
    Hi @Antoine Chalons. Can you please try out the new 1.0.1 release and let us know if this resolves your issue. I think we've fixed it, and would love to hear your feedback.
  36. 1 point
    DP.mp4 it also shows up at unexpected moments, e.g when doing a save all from the lvproj window see video
  37. 1 point
    Yes, when the DP shows up as I open a project it is pinned. See attached video : I have a small project already open with the main.vi running Then open a DQMH project >> DP shows up pinned Untitled.mp4
  38. 1 point
  39. 1 point
    I'm having the same issue, looking forward to a fix.
  40. 1 point
    It wasn't my video, just a forum topic of the tool i'm using. You can find my recorded example below. Even though I unpin the palette and close the window, it is still being opened.
  41. 1 point
    Hi Jim Yes i am able to use the palette if not scrolling. It is not freezing after a period of time. Below are also some observations: The palette will freeze if I: Select "System theme" from the combo box (the classic and flat works fine) Maximize the palette The palette will NOT freeze if a I scroll with a limited number of controls shown (for example when filtering to show only boolean controls)
  42. 1 point
    Hello JKI, I found two issues on your recent release of JKI Flat UI controls V2.0. Those details are follows, 1. When I changing to true state on settings control, it shows different image instead of settings image. 2. When I try to enter values on numeric controls, the cursor hover expending beyond that control size. Typically, the cursor hover size would be within the numeric control size. I hope, these information's may help to improve changes on your Flat UI controls V2.0 Regards, SABARI SARAVANAN M
  43. 1 point
    I ran across a problem in a project where, after creating and initializing the class under test in the setUp VI, unbundling it in the test VI returns a default object rather than the one I instantiated. setUp.vi testCount.vi I've attached a project with the class under test (ListImp) and two test cases. Both test cases have (as near as I can tell) identical setUp code and identical code in the test method (testCount). However, one test passes while the other test fails. Any idea what's causing this? [Edit - The about box reports "version 3.0.1.294 (Feb 11 2019)".] [Edit 2 - Another piece of potentially relevant information is the Test_ListImp..._2 test class was brought forward from an older version of VI Tester. I don't know what version, but according to my repository it was sometime before Feb. 2013. The other test class (the one that passed) was created with the current version of VI Tester.] VI Tester Error.zip
  44. 1 point
    Can i Link this case structure viewer to my existing case structure. i already created one VI using Enum based state machine.Now i want to convert it to JKI state machine.is there any possibility to convert with minimum changes instead of re-implementing.
  45. 1 point
    Open "Compare to Constant.xnode" with a text editor. Near the bottom, delete the two items "Untitled 4 (SubVI)" and "Untitled 5 (SubVI)" Then it will build.
  46. 1 point
    single step sounds good - and should work in both direction Last/Next Step dynamic state generation - maybe JSON imported State"Objects" (export fct would be nice 2)
  47. 1 point
    Hello. I am trying to make a measurement program. Since this measurement takes a long time, it is necessary to be interrupted by the user's operation so that it can return to the measurement standby state. Is there a smarter way than inserting lots of checking the local variable of the break button during the measurement sequence?
  48. 1 point
    Hi @Jim Kring , I have tried out the new build(3.0.2) and it works fine for me. Thanks for the immediate fix Thanks, Bhargavi Gowri.
  49. 1 point
    Hi @JimKring, I have moved to the approach of creating the DOM reference in setUp.vi of Test Suite. I will let you know if I face any problem. For now, Thanks, Bhargavi Gowri.
  50. 1 point
    Hi @JimKring I have attached the sample project, which demonstrates the issue that I am facing. I have also attached the image, which shows the DOM ref values in New.vi of test suite and setUp.vi of the test case. Please let me know if you need any details. Thanks, Bhargavi Gowri. Sample Code.zip
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.