Jump to content

Chris Reed

Members
  • Content Count

    12
  • Joined

  • Last visited

Posts posted by Chris Reed


  1. When I click on the Check for Available packages icon, VIPM goes to the following sites:

     

    http://www.jkisoft.com/packages

     

    http://ftp.ni.com/evaluation/labview/lvtn/vipm

     

    http://download.ni.com/evaluation/labview/lvtn/vipm

     

    Now If I type these addresses into IE8 I can reach the bottom two sites, but when I try the jkisoft site it says:

     

    Forbidden

    You do not have permission to access this document.

    --------------------------------------------------------------------------------

    Web Server at jkisoft.com

     

     

    I assume this is where the oglib packages are kept is that right?

    If so I'll get our IT Dept. to open up the firewall for this website and see if that works.

     

    Chris


  2. Yes I can access the Tools Network View (and it looks really nice).

     

    I changed my Network Settings to "Direct Connection" and clicked on the "Check All Package Repositories" button, but the system timed out and popped up the Error Message, "There was an error checking the network for new packages..."

     

    I've attached the error log file for today.

     

    I should add that we are running Trend Micro OfficeScan and I've read in the forums that this might cause a problem.

     

    Chris

    August-12-2011.txt


  3. Um! So what is the solution to this problem, because after I upgraded to VIPM 2011 all my OpenG library packages (oglib) finally uploaded to version 4.0 (that's a whole other story).

     

    But then if I click on the OpenG Toolkit package (v1.0.0.5) and select "Install" the Action Confirmation window appears which shows some packages have the auto-conflict Status (see 1st attachment).

     

    If I press the Continue button then the "No packages in Library" message appears (see 2nd attachment).

     

    If I select any one of the oglib packages (see 3rd attachment) and select Install Other Version, VIPM seems to just hang (cursor changes to hour glass). The status bar at the bottom says Ready ... but the Progress bar keeps on flickering on and off as if it's mass compiling or something.

     

    Also the Install & Upgrade Package(s) and Uninstall Package(s) icons in the toolbar are flickering as well as if they are trying to get out to the internet.

     

    Chris

    Dependencies Conflicts Error.png

    No packages in Library.png

    Install oglib package Hang Error.png


  4. OK tried that, but unfortunately none of my packages updated and it just recreated those two files again :(

     

    To test the network connection I successfully downloaded and installed the Rename LVOOP Labels package :)

     

    But then it didn't work when I tried to install the LabVIEW Interface for Arduino package :(

     

    So I'm still not enitrely sure whether I can get out through our proxyserver. I will get our IT Dept. to investigate further.

     

    Thanks for all your time and help Michael.

     

    Chris


  5. OK I tried renaming the *.ogpd file, but that didn't make any difference.

    So then I copied the *.ogpd file from the Windows7 laptop that has the latest OpenG libraries and put it into my WinXP Desktop (with the old oglib libraries) and fired up VIPM again, but that didn't help him.

     

    I'm not sure what you mean by caching on the Source Computer - do you mean the repository hosting the source files on the internet?

     

    I have attached the two *.ogpd files, but they seem pretty much the same, although the Windows7 version is slightly larger.

     

    Chris

    ogpd files.zip


  6. Hi Michael,

    Well it looks like it might be a connection issue since this is the last package in the *.ogpd file

     

    [Package oglib_variantconfig-2.7-2]

    Package.URL=sf://opengtoolkit/oglib_variantconfig-2.7-2.ogp

    Icon.URL=oglib_variantconfig-2.7-2.bmp

    Spec.URL=oglib_variantconfig-2.7-2.spec

    Package.MD5=d03e4825133cf42325d544563fe03565

    Platform.Exclusive_LabVIEW_Version=>=6.1

    Platform.Exclusive_OS=All

    Dependencies.Requires=ogrsc_dynamicpalette>=0.2,oglib_lvdata>=2.0,oglib_string>=2.0,oglib_error>=2.0

     

    But what I don't understand is that it doesn't report any errors when it goes off to the network to find the lastest packages. I can see the search paths come up in the Status bar and no Error file is saved in the Application Data directory. Also it "seems" that all(?) my other packages (eg. MGI) are up to date when compared to the Windows 7 (Direct Connection) Laptop.

     

    Chris


  7. Thanks for the reply Michael, but I have installed all the packages (as shown in the attached picture) and you can see under the Install Other Version it doesn't show the latest version of 4.0.0.5.

     

    And if I click on Upgrade All Installed Packages it just tells me that all my packages are at the latest revision and No updates are required.

     

    Chris

    VIPM Screen Snapshot.jpg


  8. Dear JKI Team,

    Firstly here is all my system info:

    VIPM 2010 (2010.0.2) Community Version running through a ProxyServer

    LabVIEW 2010 (v10.0)

    Windows XP SP3

    I attached an error log file - but that doesn't really relate to my current problem and I was blocked from attaching my Setting.ini file. I suppose I could paste it into the Topic if you really need it.

     

    Anyway my problem is VIPM "seems" to be working through our Proxy Server, since when I check for All Package Repositories it goes off to ftp.ni.com and www.jkisoft.com and says that it did not find any updates for my installed packages - all good so far....

     

    However on another outside laptop running through a Direct Connection with the same version of VIPM (but on Windows 7 Home with LV2010 SP1) it has just downloaded all the latest updates to the OpenG Library (ie. to version 4.x), but my version is still showing the old oglib_xxx library packages.

     

    But then I look at say the MGI_General_VIs package and my version is at 3.8-10, but the laptop is at an earlier version of 3.4-2.

     

    How can we tell what are the latest package versions and any idea why VIPM doesn't seem to be updating to the latest versions?

     

    Thanks Chris

    January-26-2011.txt

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.