Jump to content

ASTDan

Members
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

1 Neutral
  1. Hello Jim, I figured it out! Yes dynamically adding elements to a variant worked! Thanks for you help Jim!
  2. Thanks for the Reply Jim, The requirements are I want my customer to use XML because I think they need it. They want a file that looks warm and fuzzy in excel, because excel is all they know. Down the road when they have 80 gazillion xml files, porting the xml data to data base will be a snap (which I think would be cool). I am trying to figure out a data structure using the Easy XML toolkit that would satisfy both wayward engineers. I tried the attribute. Cool, but didn't quite work. How do I make Variant representation of cluster and construct its elements and their names dynamically? I have the OpenG LabVIEW Data tools Library. What functions would allow me to do this? Thanks Dan
  3. Hello, Is there a way to create programmatic element names i.e. element names defined at run time not edit time. For example I have data that I want to associate to it's location i.e. station 1, station 2, etc. I only know how many stations I have at run time. I would like the stations to appear as columns in an xml table in excel. The way I think to do this is to define element names at run time. I think I need something like the following. <Current_Data> <Station_1>1</Station_1> <Station_2>2</Station_2> <Station_3>3</Station_3> <Station_4>4</Station_4> <Station_5>5</Station_5> The number of stations are unknown and they may not be sequential. Any help would be appreciated. Thanks Dan
  4. ASTDan

    Loading Tests

    Hello Jim, Finally got around to try this. I stopped auto populating and no luck.
  5. ASTDan

    Loading Tests

    Hello, I am having trouble loading tests. When VI tester starts it doesn't find my tests. I can manually load 1 test by File/Open File or test class. I can't load multiple tests. I have my classes in folders. Do the test classes need to be in the top level of my project? I have them in a auto populating folder called "Unit tests? Thanks Dan
  6. ASTDan

    UI Testing

    Hello, I was wondering if there any plans to implement UI testing into VI tester. Here is a blog about a tool NI is considering UI Testing How do you guys test UIs? Thanks Dan
  7. Good luck trying to figure out a good solution! I look forward to VI tester updates. So far I like working with VI tester. It is turning out to be an easier transition than I thought.
  8. Thanks Jim! Is this a LabVIEW thing? For example when people implement an OO paradigm is "LabVIEW taking a long time to reserve class members" something that needs to be taken into consideration? I don't have a lot of experience with OO and am trying to learn more about it. Thanks Dan
  9. Hello, I am running VI tester with LabVIEW 2009. I have created about 13 test cases. When I call VI tester to run my tests it takes a few minutes to load. Is this normal? Is there a setting or technique I can use to speed this up? Thanks Dan
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.