Jump to content

Antoine Chalons

Members
  • Content Count

    14
  • Joined

  • Last visited

  • Days Won

    3

Everything posted by Antoine Chalons

  1. Ok, thanks for this, no less than what I was expecting from JKI 🙂 I don't really use NXG yet, I installed NXG 4.0 and had a quick look around, nothing more for now. Not sure yet when I'll start migrating my customer project, probably around end of 2020. At the moment I'm listing all the NI modules/drivers and "community modules" that I use in CurrentGen and start checking if and when they'll be available in NXG.
  2. I'm in no rush to move project to NXG, but I am curious, I saw on GitHub that JKI is has worked on a JKI State Machine for NXG and I was wondering if there was any similar project for EasyXML. I'm assuming the transition of this toolkit is not going to be a huge problem, am I right? I'm also assuming some NXG early birds have already tried the transition of EasyXML, anyone?
  3. version 2.0.1.24 requires JDP version 1.0.4.93 but the latest available version is 1.0.4.92 See image :
  4. Use case : When working / debugging on a PreBuild or PostBuild action VI, I sometime keep the Pre/Post Build VI' FP & BD open for debugging in the context in which it was opened by LabVIEW when the build was started (NI.LV.MxLvProvider context instead of the usual main application context that you can see at the bottom left corner of the VI windows). When I am in this context, if I open the JDP, try to drag a control onto the front panel of the VI that is in the NI.LV.MxLvProvider context it doesn't work The work-around is to drag the control into another VI in the main app context, cut it and past it on the VI in the other context Not a big problem because I rarely do UI in that context but thought I'd mention it anyway. See video : feedback JDP.mp4
  5. DP.mp4 it also shows up at unexpected moments, e.g when doing a save all from the lvproj window see video
  6. Yes, when the DP shows up as I open a project it is pinned. See attached video : I have a small project already open with the main.vi running Then open a DQMH project >> DP shows up pinned Untitled.mp4
  7. The design palette shows up every time I open a LabVIEW project, is it the intended behavior? And is it possible to change this? Cheers
  8. Here is what I'm currently doing : Is there a better way? xml catch.vi
  9. Here is the content of an XML file that I need to load : I don't know if this is standard XML... In capabilities, "yes" and "no" are options and in currentValue "no" is the selected value. Is there a way, using EasyXML, to read capabilities as an array of string and retrieve "yes" and "no" read currentValue as a string in order to retrieve "no" Thanks in advance
  10. Cheers @Jim Kring, lots of challenging problems to solve with LabVIEW 🙂 EasyXML Toolkit is fabulous, I remember there use to be a paid version, it's really nice of JKI to have put it OpenSource on GitHub! If there was a way to donate money to thank the developers, I would!
  11. Hello, I'm trying to load data from an XML file, it contains this : <supportedVariation> <objectGroup>0</objectGroup> <variation>1000</variation> <description>Device 1</description> </supportedVariation> <supportedVariation> <objectGroup>1</objectGroup> <variation>2000</variation> <description>Device Attributes 2</description> </supportedVariation> <supportedVariation> <objectGroup>2</objectGroup> <variation>3000/variation> <description>Device 3</description> </supportedVariation> The Array name is supportVariation and the element of the array is a cluster that contains 3 elements (objectGroup (I32), variation (I32) and description (string)). It seems to me that EasyXML can't load this, I hope I'm wrong. In LabVIEW created an Array named "supportVariation" containing a cluster that I named "cluster" that contains my 3 elements objectGroup (I32), variation (I32) and description (string) EasyXML "sees" all the element in the array but doesn't load the value of the cluster elements because the file doesn't contain the cluster name. If I use EasyXML to write the cluster array, the created xml file has the cluster name. Edit : Ha... in fact it works just fine (which is amazing), After some poking and debugging I just found out that I had an extra cluster layer in my control (cluster frames are so thin these days).
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.