Jump to content
Marc Blumentritt

Error building package which includes 2 classes

Recommended Posts

Update: This issue has been resolved in the latest version of VIPM. If you are still experiencing issues, please read this troubleshooting guide. You can also contact us with your code here.

 

 

 

Hi,

 

I'm trying to build a package, which includes 2 classes foo and bar, where bar is a child of foo. The build process stops with the following message:

 

There was an error building your package during the source distribution step.

Please make sure that you have properly installed OpenG Builder and that you have run it by selecting Tools>>OpenG Builder from LabVIEW menu.

 

OpenG Builder is running fine, since I have build several packages with it (before and after the error message). Only this package does not work and I think, the reason is the inclusion of the 2 classes.

 

I'm using LabVIEW 8.5 (German version). All OpenG packages are up to date. The classes are using standard VIs (mainly TDMS palette) and some of my self made package VIs.

 

Can you confirm this behavior?

 

Regards,

Marc

Share this post


Link to post
Share on other sites

Hi Marc,

 

Currently, VIPM has some trouble building classes that use dynamic dispatch. This is due to the fact that LabVIEW requires that each class's implementation have the same VI name as the parent's VI. When VIPM builds the package, it cannot put both VIs into the same LLB, since LLB's are flat. We're looking into ways to resolve this issue.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

Has this issue been resolved? If not, is there a known workaround?

I'm thinking about putting the child class in a separate package but I don't know if I'll have problems with namespacing, and I find it's not a very efficient way if I want to distribute my plugins all separate: it could make for an impressive number of packages. It probably would anoy people if I started posting these on LVTN for example...

 

Just a thought, would it be possible to change the filenames in the package as a pre-build instruction and rename them with proper namespacing on install?

 

François.

 

Hi Marc,

 

Currently, VIPM has some trouble building classes that use dynamic dispatch. This is due to the fact that LabVIEW requires that each class's implementation have the same VI name as the parent's VI. When VIPM builds the package, it cannot put both VIs into the same LLB, since LLB's are flat. We're looking into ways to resolve this issue.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

I just put different libraries/classes in different .LLBs (or folders) in the same package. No dramas. Is that something you can do?

 

Hummm, lately I tried to put the classes in llb files and I got errors that VIPM could not detect the LabVIEW version of the files. At first, I attributed that to a file corruption and I took the VIs out of the llb when I resaved them. I thought that was it, but I reput it in a llb and couldn't build again.

 

If I can make it work with LLBs, I'd be glad to do it. Does it mean I need to deploy with "Destination Type" == Directory ?

Edited by normandinf

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.