Jump to content
Marc Blumentritt

More control over final file names

Recommended Posts

Hi,

 

I tried to create a package consisting of custom probes. But since the VIs are placed inside a llb, which starts with an underscore, LabVIEW does not add these VIs as custom probes to my right-click menu.

 

Therefore I would like to see the possibility to have more control over the final file names inside the package. Perhaps this could be an advanced setting inside the namespace options? And while we are at it, I would like to choose to install the VIs inside a folder instead of a llb.

 

Regards,

Marc

Edited by Marc Blumentritt

Share this post


Link to post
Share on other sites

Hi Marc,

 

You're right that VI Package builder doesn't support the custom probes use case -- it was designed specifically for packaging up reusable VIs. However, I think that we might be able to help you. I think that you could create a post-build hook VI (download template here) that removes the underscore from the LLB file name. Take a look at the docs and let me know if you have any questions. I'd be happy to try to help you out, as I've got some experience with creating build hooks.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites
I think that you could create a post-build hook VI (download template here) that removes the underscore from the LLB file name. Take a look at the docs and let me know if you have any questions. I'd be happy to try to help you out, as I've got some experience with creating build hooks.

 

Using a hook VI was my first idea, too (s. attachment). It did not work for me.

Any idea?

 

Marc

Remove_Underscore.vi

Share this post


Link to post
Share on other sites
Using a hook VI was my first idea, too (s. attachment). It did not work for me.

Any idea?

 

Marc

 

Hi Marc,

 

Thanks for posting this. I'll take a look and get back to you, shortly.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites
Using a hook VI was my first idea, too (s. attachment). It did not work for me.

Any idea?

 

Marc

 

Hi Marc,

 

Here's a post-build hook VI that should work for your custom probe package. It will remove the underscore from the LLB file inside the package. This is a bit of a hack, but it should work for you.

 

Thanks,

 

-Jim

Remove_Underscore_from_LLB_Name_in_VI_Package.vi

Share this post


Link to post
Share on other sites
Here's a post-build hook VI that should work for your custom probe package. It will remove the underscore from the LLB file inside the package. This is a bit of a hack, but it should work for you.

 

Thanks! I will try it out, but I'm sure it will work :D

 

Marc

Share this post


Link to post
Share on other sites

Hi Marc,

 

It's been a while and I'm curious to hear back from you about whether this post-build hook allowed you to correctly install your custom probes package.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.