Jump to content
Yair

Package building stops in the middle

Recommended Posts

I have the community edition version of VIPM (2.0.3) with all the relevant packages installed and up-to-date.

 

When I try to build a package, the builder gets stuck in the middle looking for a couple of typedefs (I believe it's in the <LabVIEW>\Resource\OpenG\Build folder, but I'm not near that PC at the moment). The typedefs have "linker" in their name.

 

I did find the typedefs in an LLB in the OpenG builder folder (with an addition of the builder namespace, "OGB", I believe) and when I selected them the build seemed to go through, so I guess I could just copy and rename those typedefs and it would work every time, but I figured I should report it.

Share this post


Link to post
Share on other sites

Hi Yair,

 

Please run OpenG Builder from the LabVIEW Tools>>OpenG Builder... menu. It should tell you that it needs to mass-compile itself. Let it do this, then restart LabVIEW. This should fix the issue. Please let me know if it does.

 

Thanks,

Share this post


Link to post
Share on other sites

OK, that seems to have done the trick. You might wish to have it somewhere in the list of steps of installing the package (in general, it would be nice if VIPM could automatically handle the mass compile after installation).

 

 

Another issue (which is probably only related to the RCF) is that at the end of the package build process, the builder was looking for a VI at "vi.lib\addons\...\Right Click API.llb\93A2BE868C4C04F3..." (I truncated it, I assume it should be enough).

 

If I browse for the file, it appears in the window title as if it should be in the .lvlib which was generated for the specific package. If I ignore it, the build continues normally and produces a seemingly normal package (I haven't tried installing it).

 

P.S. Can you change my display name to Yair? It would provide order. Thanks.

Share this post


Link to post
Share on other sites

Incidentally, this reminds me of another issue I had with the package building - VIPM did not manage to unload the VIs which were used by the RCF and kept showing the dialog about how the VIs have to be closed. Stopping the RCF allowed me to continue with the build.

Share this post


Link to post
Share on other sites
Incidentally, this reminds me of another issue I had with the package building - VIPM did not manage to unload the VIs which were used by the RCF and kept showing the dialog about how the VIs have to be closed. Stopping the RCF allowed me to continue with the build.

 

Hi Yen,

 

This is a known issue. Basically, if the RCF is running and has "development/source" plugins loaded, VIPM will not be able to build your package. The way to work around this is to either stop the RCF or to disable loading of source plugins by setting your plugin development source path to empty path. Note, I've file a feature request to add a checkbox to enable/disable all source plugins in the options dialog:

 

Case 7778: "Enable/Disable source plugins checkbox on options dialog"

 

1.png

Share this post


Link to post
Share on other sites
P.S. Can you change my display name to Yair? It would provide order. Thanks.

 

Done.

 

Did you see post #3?

 

Yes. If there's something else specific that I missed, let me know.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.