Jump to content
Sign in to follow this  
TonP

Installing VIPM 2010 on Windows 7 Dutch

Recommended Posts

When I tried to install VIPM 2010 on my computer (running Windows 7 in dutch) I received the following error dialog:

VIPMInstaller.png

I copied the folder mentioned in the dialog

After clicking continue the installer closed (and the source temp folder disappeared).

 

Looking in the folder there was an executable VI Package Manager.exe

Running this launched started VIPM as expected, and I choose the community edition,I quit and then I copied it over my existing VIPM version.

Then if I started VIPM I saw a splash screen for a few seconds and then VIPM disappeared.

Starting VIPM from the temporary copied folder still succeeded.

 

Ton

Edited by TonP

Share this post


Link to post
Share on other sites

That got the installer finished however VIPM won't start.

After I've started VIPM I noticed once that the menu items were garbled (unicode issue?). I cannot get a screenshot since it goes away too fast.

 

When I look at the VIPM error files I see the following content:

=========== START of VIPM Error Message ===========

An internal VIPM Error has occured on: dinsdag augustus 03, 2010 at 08:41:43

 

= Automated Message Start =

Error -600 occurred at Query Registry Key Info.vi

Possible reason(s):

LabVIEW: Ϊȷ¶¨µÄWindows×¢²á±í´íÎó¡£

= Automated Message End =

 

= User Defined Message Start =

Error(s) Generated in Splash Window

= User Defined Message End =

 

= Error Handler Call Chain Start =

VIPM Splash.vi

= Error Handler Call Chain End =

=========== END of VIPM Error Message ===========

One thing to note is that the used date format is slightly off. The returned date is local 'dinsdag augustus 03', however the time was US without a PM addition 08:41:43 (it was 20:41 in the evening).

 

Ton

Share this post


Link to post
Share on other sites

Any ideas?

I can use VIPM, only I have to start it first from the location where I ran it from the first time. It seems like I cannot uninstall and reinstall it.

Starting as Admin won't help.

 

Ton

Share this post


Link to post
Share on other sites

It seems to me that somehow the LabVIEW Runtime engine has some kind of unicode issue. If this is the case then there could be multiple issues which would render VIPM unusable on your system since VIPM, the installer and the uninstaller, are all written in LabVIEW, which relies on the LabVIEW 2009 runtime engine behaving correctly.

 

To fix this I would try the following:

- Uninstall VIPM with brute force (if the normal uninstaller doesn't run) by deleting the following folders:

C:\Documents and Settings\All Users\Application Data\JKI\VIPM

C:\Program Files\JKI\VI Package Manager

- Perform a repair on the LabVIEW 2009 (32bit) Runtime Engine. Or better, uninstall and re-install, if possible.

- Reinstall VIPM.

Share this post


Link to post
Share on other sites
It seems to me that somehow the LabVIEW Runtime engine has some kind of unicode issue. If this is the case then there could be multiple issues which would render VIPM unusable on your system since VIPM, the installer and the uninstaller, are all written in LabVIEW, which relies on the LabVIEW 2009 runtime engine behaving correctly.

 

To fix this I would try the following:

- Uninstall VIPM with brute force (if the normal uninstaller doesn't run) by deleting the following folders:

C:\Documents and Settings\All Users\Application Data\JKI\VIPM

C:\Program Files\JKI\VI Package Manager

- Perform a repair on the LabVIEW 2009 (32bit) Runtime Engine. Or better, uninstall and re-install, if possible.

- Reinstall VIPM.

That got me somewhere, I can see english menu options (still briefly), but is looks like the VI is idle (I see a run arrow) and the errors generated are the same:

= Automated Message Start =

Error -600 occurred at Query Registry Key Info.vi

Possible reason(s):

LabVIEW: Undetermined Windows registry error.

= Automated Message End =

 

= User Defined Message Start =

Error(s) Generated in Splash Window

= User Defined Message End =

 

= Error Handler Call Chain Start =

VIPM Splash.vi

= Error Handler Call Chain End =

=========== END of VIPM Error Message ===========

Are there any specific registry keys you are checking?

 

Ton

Share this post


Link to post
Share on other sites
Are you running 32 or 64 bit windows?

32-bit.

 

Ton

EDIT:

And the problems spread. Somehow I cannot connect to LabVIEW directly.

Here's a relevant section from the VIPM error log:

=========== START of VIPM Error Message ===========

An internal VIPM Error has occured on: zaterdag augustus 14, 2010 at 10:21:32

 

= Automated Message Start =

Error 1379 occurred at Open Application Reference in E7F5DD0D4BC46BD48452C7AAE637066B->VIPM

Configure LV Port.vi->872238873F1BAA0C599ABDDA5D5A653E.lvlib:VIPM Options Window.vi->VIPM Main

Window.vi

Possible reason(s):

LabVIEW: The user failed a security authentication check.

= Automated Message End =

 

= User Defined Message Start =

Testing the LV connection from the test connection dialog.

= User Defined Message End =

 

= Error Handler Call Chain Start =

VIPM Main Window.vi->

872238873F1BAA0C599ABDDA5D5A653E.lvlib:VIPM Options Window.vi->

VIPM Configure LV Port.vi

= Error Handler Call Chain End =

=========== END of VIPM Error Message ===========

And I enabled tcp.server.log in the LabVIEW ini and this is the log:

2010.08.14 - 10:21:32; ## Receiving message

hdr={err= 0; uID=0x00000006; len= 8; msg="kTSClientSaysHeaveno"(0)}

conn @0xEF99CE0; cookie=0x2D500000; "127.0.0.1"

2010.08.14 - 10:21:32; ## Closing connection

SERVER closing ref=0x2D500000; "127.0.0.1"

2010.08.14 - 10:21:32; ## New incoming connection

CONNECTION ACCEPTED; client="127.0.0.1" (127.0.0.1)

I shut down my firewall, allowed acces from any computer, no success.

 

One minor usage issue:

When I open the VIPM configuration dialog, and try to test a port setting, if this connection fails, the port setting dialog is closed, and I am returned to the configuration dialog. I would prefer to stay in the Port configuration dialog to test and adjust the port.

 

Ton

Edited by TonP

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.