Jump to content
Sign in to follow this  
dbaechtel2

No Packages Listed after upgrade to VPIM 2010

Recommended Posts

I was running the previous version of VPIM OK. Then I got a message that a new version was available and I installed that. With VPIM 2010, after I do a Check All Repositories, it says "... No new packages found since last time ...", but no packages are listed.

 

If I locate MGI_General_VIs-3.7-18.ogp and do a Open Package Files, it seems to find it and some information about it briefly, but still no pakages are listed. Install button does some searching but still no packages are listed.

 

Tools > Options > Labview shows tested connections to both Labview 2009 and Labview 2010, both on the same port. STIL no packages are listed.

 

If I try and list installed packages, still no packages are listed.

 

I uninstalled VPIM 2010 and installed it again, still no packages are listed. :o

 

How can I get VPIM 2010 to scan the repositories and LIST all of the available packages?

 

How can I get VPIM 2010 to install the same packages tat I had installed in Labview 2009 into LabVIEW 2010 ?

Share this post


Link to post
Share on other sites
Can you give me some more info on your system?

What OS are you running?

What was your previous VIPM version, 3.0?

 

I am running Win XP SP3 with all recent patches.

I'm not sure what VIPM I was running, I downloaded it from JKI about 2 weeks ago.

Apparently VIPM has some database or storage of packages that it thinks that it knows, but it is no displaying any of them.

That is why the Check All Package Repositories says that there haven't been any changes since the last update.

 

How do I clear that storage that it thinks that it knows. The Uninstall and install did not clear that, like it should.

How do I get rid of ALL VIPM data so that it starts fresh on new download?

Are there any internal logs that would shed light on what is happening?

Share this post


Link to post
Share on other sites

VIPM has a folder structure containing the downloaded packages and the trace of installed packages under the All users Appdata folder. This folder is located on a German XP under "D:\Dokumente und Einstellungen\All Users\Anwendungsdaten\JKI\VIPM", where D: is the drive I have Windows installed. I think normaly on an English XP it should read: "C:\documents and settings\All Users\Appdata\JKI\VIPM".

Share this post


Link to post
Share on other sites

Well. let's try to figure this out. There are two files I would like you to attach from your system.

 

The first file is your VIPM configuration located here:

WinXP: C:\Documents and Settings\All Users\Application Data\JKI\VIPM\Settings.ini

Win7\Vista: C:\ProgramData\JKI\VIPM\Settings.ini

 

The second is your VIPM error log located here (the most recent error file inside there):

WinXP: C:\Documents and Settings\All Users\Application Data\JKI\VIPM\error

Win7\Vista: C:\ProgramData\JKI\VIPM\error

 

This will help me troubleshoot the problem.

 

However, If you would like to reinitialize your VIPM installation then I can provide instructions on how to uninstall VIPM and all the package installation information. This would require you to re-install your packages but it would definitely fix the problem. I would only recommend this as a last resort if we cannot figure out a solution.

Share this post


Link to post
Share on other sites
Well. let's try to figure this out. There are two files I would like you to attach from your system.

 

The first file is your VIPM configuration located here:

WinXP: C:\Documents and Settings\All Users\Application Data\JKI\VIPM\Settings.ini

Win7\Vista: C:\ProgramData\JKI\VIPM\Settings.ini

 

The second is your VIPM error log located here (the most recent error file inside there):

WinXP: C:\Documents and Settings\All Users\Application Data\JKI\VIPM\error

Win7\Vista: C:\ProgramData\JKI\VIPM\error

 

This will help me troubleshoot the problem.

 

However, If you would like to reinitialize your VIPM installation then I can provide instructions on how to uninstall VIPM and all the package installation information. This would require you to re-install your packages but it would definitely fix the problem. I would only recommend this as a last resort if we cannot figure out a solution.

 

Attached are the files that you wanted. I had to add .txt extension to Settings.ini file in order to send it to you.

 

Let's work quickly to get the information that you need to fix. Otherwise let's reinstall the application so that I can get runniung again.

 

THANKS.

August_07_2010.txt

Settings.ini.txt

Share this post


Link to post
Share on other sites

Try deleting this entire section from your settings.ini file. Then restart VIPM.

 

[Repository]

Repository URLs. = "1"

Repository Folders. = "0"

Perform SVN Update? = "Prompt"

Perform SVN Commit? = "Prompt"

Disable VI Package Network Connection = "FALSE"

Repository Names. = "0"

Repository Enabled. = "0"

Repository Authorized. = "0"

Repository URLs 0 = "http://www.ni.com/labviewtools"

 

Also, Do you have restricted access to your computer? I'm asking because I see a lot of permissions errors. VIPM can run without admin access but certain configurations can trip it up. Specifically, I see errors accessing C:\Documents and Settings\Don\Local Settings\Temp\icon.bmp

If that file exists, try deleting it and restarting VIPM.

Share this post


Link to post
Share on other sites
Try deleting this entire section from your settings.ini file. Then restart VIPM.

 

[Repository]

Repository URLs.<size(s)> = "1"

Repository Folders.<size(s)> = "0"

Perform SVN Update? = "Prompt"

Perform SVN Commit? = "Prompt"

Disable VI Package Network Connection = "FALSE"

Repository Names.<size(s)> = "0"

Repository Enabled.<size(s)> = "0"

Repository Authorized.<size(s)> = "0"

Repository URLs 0 = "http://www.ni.com/labviewtools"

 

Also, Do you have restricted access to your computer? I'm asking because I see a lot of permissions errors. VIPM can run without admin access but certain configurations can trip it up. Specifically, I see errors accessing C:\Documents and Settings\Don\Local Settings\Temp\icon.bmp

If that file exists, try deleting it and restarting VIPM.

 

I deleted the section that you mentioned from the Ini file. I restarted VIPM, it cam up blank and still does not list and packages after Checl All Package Reposities. The change to the Ini file had no effect.

 

I have full Administrative access on this machine.

 

There is no file C:\Documents and Settings\Don\Local Settings\Temp\icon.bmp on my machine.

 

VIPM added the following to the end of the settings.ini file:

 

[Repository]

Repository URLs.<size(s)> = "0"

Repository Folders.<size(s)> = "0"

Perform SVN Update? = "Prompt"

Perform SVN Commit? = "Prompt"

Disable VI Package Network Connection = "FALSE"

Repository Names.<size(s)> = "0"

Repository Enabled.<size(s)> = "0"

Repository Authorized.<size(s)> = "0"

Share this post


Link to post
Share on other sites

It's possible that your firewall software on your machine is blocking access to the internet from VIPM. If you have one, please disable it temporarily to see if this fixes it. If it does, then add an exception to your firewall for VIPM.

 

Another option is that your corporate network is configured where you are required to go through a proxy server. If this is the case then, you need to configure VIPM to use that proxy server. More information can be found here.

 

If you want to perform a clean install of VIPM (note, you will need to reactivate VIPM if you're a Professional or Enterprise customer):

- Perform an uninstall from: All Programs>JKI>VI Package Manager Uninstall

- Delete the following folders:

C:\Documents and Settings\All Users\Application Data\JKI\VIPM

C:\Program Files\JKI\VI Package Manager

- Reinstall VIPM.

Share this post


Link to post
Share on other sites
It's possible that your firewall software on your machine is blocking access to the internet from VIPM. If you have one, please disable it temporarily to see if this fixes it. If it does, then add an exception to your firewall for VIPM.

 

Another option is that your corporate network is configured where you are required to go through a proxy server. If this is the case then, you need to configure VIPM to use that proxy server. More information can be found here.

 

If you want to perform a clean install of VIPM (note, you will need to reactivate VIPM if you're a Professional or Enterprise customer):

- Perform an uninstall from: All Programs>JKI>VI Package Manager Uninstall

- Delete the following folders:

C:\Documents and Settings\All Users\Application Data\JKI\VIPM

C:\Program Files\JKI\VI Package Manager

- Reinstall VIPM.

 

Turning off firewall did not help.

Adding exception in firewall for VIPM did not help.

It appears it is getting things from the Internet. It says "getting http://...."

Still no list of packages.

 

I am not on a corporate network. I am not using a poxy.

 

VIPM worked on this machine on this network befor the upgrade to VIPM 2010.

Share this post


Link to post
Share on other sites
It's possible that your firewall software on your machine is blocking access to the internet from VIPM. If you have one, please disable it temporarily to see if this fixes it. If it does, then add an exception to your firewall for VIPM.

 

Another option is that your corporate network is configured where you are required to go through a proxy server. If this is the case then, you need to configure VIPM to use that proxy server. More information can be found here.

 

If you want to perform a clean install of VIPM (note, you will need to reactivate VIPM if you're a Professional or Enterprise customer):

- Perform an uninstall from: All Programs>JKI>VI Package Manager Uninstall

- Delete the following folders:

C:\Documents and Settings\All Users\Application Data\JKI\VIPM

C:\Program Files\JKI\VI Package Manager

- Reinstall VIPM.

 

Nothing else worked. I had to do complete uninstall, delete and install.

 

Now it works OK.

 

THANKS.

Share this post


Link to post
Share on other sites

I too just upgraded to labview 2010 and to the latest version of VIPM. In VIPM 2010, no packages show up for either labview 2009 or labview 2010. I uninstalled and reinstalled VIPM 2010 several times. I then reinstalled VIPM 3.0. In that version, my installed labview 2009 packages show up, but there is still nothing for labview 2010. I'm using windows 7 64 bit. Each time I've uninstalled VIPM, I've also deleted "C:\Program Files (x86)\JKI\VI Package Manager", but I've searched "C:\Users" and cannot find any file or folder having to do with JKI, so I have no idea where the application data for VIPM is and have never deleted it.

 

The only way I was able to install labview 2009 packages was to delete all other versions of labview from my computer besides 2009. Can VIPM really only handle 1 version of labview at a time? Am I going to have to delete labview 2009 to get 2010 to work? That's certainly not convenient. This is very frustrating. I wish there was just a regular installer available for open g that I could download, double click, and start using within minutes instead of jumping through hoops for hours.

Share this post


Link to post
Share on other sites

Sorry for your problems.

 

VIPM data is located at:

 

C:\ProgramData\JKI\VIPM

 

VIPM can manage multiple LabVIEW versions. No need to uninstall LabVIEW. Try uninstalling VIPM and removing the above mentioned folder before reinstalling VIPM.

Share this post


Link to post
Share on other sites
Sorry for your problems.

 

VIPM data is located at:

 

C:\ProgramData\JKI\VIPM

 

VIPM can manage multiple LabVIEW versions. No need to uninstall LabVIEW. Try uninstalling VIPM and removing the above mentioned folder before reinstalling VIPM.

 

Hey, that worked! So is "C:\ProgramData\JKI\VIPM" it the windows-7 equivalent of "C:\Documents and Settings\All Users\Application Data\JKI\VIPM"? A warning to anyone else who reads this post, you have to enable viewing hidden files/folders to see C:\ProgramData (at least in windows 7). Thanks for your help and patience, Michael; I appreciate it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.