Jump to content
Matthew Harrison

VIPM 2010 Fails to Open a Single Package

Recommended Posts

Steps to reproduce:

1. Choose File->Open Package(s) from the File menu

2. Select a single package (.ogp)

 

Expected Behavior:

VIPM should add the package to the list of available packages

 

Observed Behavior:

VIPM opens the Package Information window, and very briefly displays the package info (for maybe 1/4 of a second), as in the attached image

Then the Package Information window blanks out, as in the attached image

The package is not added to the list.

 

Workaround:

Always select at least 2 packages when Opening Packages

post-2582-1281653255_thumb.png

post-2582-1281653268_thumb.png

Share this post


Link to post
Share on other sites

Hi Matthew,

 

It was great seeing you and the MGI gang at NIWeek 2010!

 

When you "open" a single package in VIPM 2010, it doesn't add the package to the VIPM package list -- it opens the Package Info Dialog. This is the designed behavior. Then, if you install the package it will appear in the package list.

 

However, it seems that you've found a bug that's preventing the package info from actually appearing in the Package Info Dialog. That's strange. Are you able to reproduce the problem or did it just happen once?

 

Thanks,

Share this post


Link to post
Share on other sites
Hi Matthew,

 

It was great seeing you and the MGI gang at NIWeek 2010!

 

When you "open" a single package in VIPM 2010, it doesn't add the package to the VIPM package list -- it opens the Package Info Dialog. This is the designed behavior. Then, if you install the package it will appear in the package list.

 

However, it seems that you've found a bug that's preventing the package info from actually appearing in the Package Info Dialog. That's strange. Are you able to reproduce the problem or did it just happen once?

 

Thanks,

 

It was really, really great to see you as well. Thanks so much for putting on that great BBQ.

 

I did not realize that the Package Info Dialog was expected behavior. I should note, however, that if multiple packages are selected, it does not come up. Instead, I get a dialog like the attached:

 

It is very reproducible. Just select a single package to add. I do not see it with the ones that automatically download from the package servers. Michael asked for an error log, so I'll post to that message with a fresh error from this morning.

 

Best Wishes,

 

Matthew Harrison

post-2582-1281716772.png

Share this post


Link to post
Share on other sites
Please submit your VIPM error log. Follow instructions here.

 

Here is the error log from this morning after a single attempt to Open a single package.

 

It appears to be complaining about file permissions, but I don't see any file permission problems, and like I said, these packages install fine as long as you select more than one.

 

-Matt

August_13_2010.txt

Share this post


Link to post
Share on other sites

Hey Matt,

 

I did not realize that the Package Info Dialog was expected behavior. I should note, however, that if multiple packages are selected, it does not come up. Instead, I get a dialog like the attached:

 

Yes, this is expected, too. If you try to open multiple packages, we assume you're wanting add them to your package list or install them all. Sorry if this isn't the most intuitive/expected behavior.

 

Here is the error log from this morning after a single attempt to Open a single package.

 

It appears to be complaining about file permissions, but I don't see any file permission problems, and like I said, these packages install fine as long as you select more than one.

 

My guess about the permission issue is that the file ("C:\Users\Matthew\AppData\Local\Temp\icon.bmp") is read-only. Can you please confirm? Can you attach your package file (or email it to customer-service@jki.net) so that we can take a look and try to reproduce this?

 

Thanks,

Share this post


Link to post
Share on other sites
Hey Matt,

Yes, this is expected, too. If you try to open multiple packages, we assume you're wanting add them to your package list or install them all. Sorry if this isn't the most intuitive/expected behavior.

My guess about the permission issue is that the file ("C:\Users\Matthew\AppData\Local\Temp\icon.bmp") is read-only. Can you please confirm? Can you attach your package file (or email it to customer-service@jki.net) so that we can take a look and try to reproduce this?

 

Thanks,

 

Ah, you are brilliant, Jim. Resetting the Read-only attribute on this file in the temp directory will fix the problem. The key discovery for me was that deleting the file causes the problem to reappear, so I checked into our package, and there are a few files (the icon among them) that are built into the package with the read-only flag set. So, we need to make sure that all of the files destined for the package get the read-only flag cleared before we build the package. Very impressive remote debugging- many, many thanks.

 

Best Wishes,

 

Matthew Harrison

Share this post


Link to post
Share on other sites
Ah, you are brilliant, Jim. Resetting the Read-only attribute on this file in the temp directory will fix the problem. The key discovery for me was that deleting the file causes the problem to reappear, so I checked into our package, and there are a few files (the icon among them) that are built into the package with the read-only flag set. So, we need to make sure that all of the files destined for the package get the read-only flag cleared before we build the package. Very impressive remote debugging- many, many thanks.

 

Best Wishes,

 

Matthew Harrison

 

Hey Matt,

 

I'm very glad we figured out the problem (icon.bmp was read-only) and that a work-around (ensuring all the package source files are writable before packaging) is feasible for you :)

 

I'll file a bug on this, so that VIPM better handles packages containing read-only files.

 

-Jim

Share this post


Link to post
Share on other sites

One more thing, Matt...

 

I assume that this package was not built using VIPM 2010 (since VIPM 2010 builds the icon.bmp file dynamically and it should never be read-only).

 

You should really try (re)building your package in VIPM 2010 -- it's pretty awesome :)

Share this post


Link to post
Share on other sites
One more thing, Matt...

 

I assume that this package was not built using VIPM 2010 (since VIPM 2010 builds the icon.bmp file dynamically and it should never be read-only).

 

You should really try (re)building your package in VIPM 2010 -- it's pretty awesome :)

 

Yes, we are still using the older tools, but we are working this month on getting switched over. Thanks for the great tools.

 

-Matt

Share this post


Link to post
Share on other sites
Yes, we are still using the older tools, but we are working this month on getting switched over. Thanks for the great tools.

 

-Matt

 

That's great to hear. We're looking forward to your feedback.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.