Jump to content
ansche

Package Builder cannot find LabVIEW 7.1

Recommended Posts

My VI Package Builder cannot access LabVIEW 7.1

 

I have 4 LabVIEW versions installed:

- LV 7.1

- LV 8.6.1

- LV 2009

- LV 2010

 

All LabVIEW Versions have been assigned a different port in VIPM and the connection tested OK.

I can install openg packages for all 4 versions.

 

 

I started my first attempt to build my own package with a utility written in LV7.1 .

In the package builder I selected LV7.1 and set the "Install Requirements" to WinXP and LV7.1 only.

 

 

There are minor problems when attempting to edit the palette icons:

The Package Builder always opens LV8.6 instead of 7.1. .

When editing the "Custom Category Palette" icon the Package Builder first asks to open LV7.1 .

When editing the "Function Palette" or "Controls Palette" icons the Package Builder does not even bother with LV7.1 and asks to open LV8.6 straight away.

 

 

The main problem however is actually building the package for LV7.1.

Again the Package Builder launches LV 8.6 instead of LV 7.1 . As my utility calls a subVI that is not part of the LV 8.6 VI.LIB the process ends here with an error message.

 

When leaving and restarting the Package builder my selected LabVIEW version is always automatically changed from 7.1 to 8.6, because the VIPM "could not locate the original LabVIEW version configured on your system"

 

Did I miss anything??

 

Anke

Share this post


Link to post
Share on other sites

Hi Anke,

 

The Package Builder in VIPM builds packages in LabVIEW 8.2 or greater.

 

Sorry for any confusion. VIPM should do a better job of letting you know about this limitation.

 

[update: I filed a bug on this issue - Case 9719]

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

Even older versions of VIPM (3, 2, 1.0) can't be used to distribute LV 7.x VIs?

What's the best way to manage VI installation in LV 7, in your opinion ?

The goal is to make our code available to as many LV users as possible, not exclude users of older versions, as long as we don't need features of newer versions.

Thanks,

Meg

Share this post


Link to post
Share on other sites

Even older versions of VIPM (3, 2, 1.0) can't be used to distribute LV 7.x VIs?

What's the best way to manage VI installation in LV 7, in your opinion ?

The goal is to make our code available to as many LV users as possible, not exclude users of older versions, as long as we don't need features of newer versions.

Thanks,

Meg

 

 

Hi Meg,

 

Sorry for the delay in response.

 

I can see how you'd like to support as wide a userbase as possible. I can't think of a great/easy solution for managing VIs saved in LabVIEW 7. IMO, VIPM provides a lot of nice packaging building and installation features, which do benefit users and provide a compelling reason for them to upgrade to LabVIEW 8.2 (or newer).

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.