Jump to content
WG-

VIMP crashes after splash screen

Recommended Posts

As the title and topic description says...

 

When I start VIMP it crashes. It happens always (except after the installation of VIMP, so generally speaking I could also just reinstall and the problem is fixed for 1 time :))

 

When i check the log it tells me that there are some permissions issues. Now the error log seems pretty straightforward to me but I'm wondering how can I fix this?

 

=========== START of VIPM Error Message ===========

An internal VIPM Error has occured on: zondag november 21, 2010 at 08:19:58

 

= Automated Message Start =

Error 8 occurred at Open/Create/Replace File in NI_LVConfig.lvlib:Save Config

File.vi->NI_LVConfig.lvlib:Close Config

Data.vi->6D821AB8B8256DEF55F850B55401760C->479EAF1BF9F9FFDA5C081E8552D0180F->VIPM Splash.vi

Possible reason(s):

LabVIEW: File permission error. You do not have the correct permissions for the file.

=========================

NI-488: DMA hardware error detected.

C:\ProgramData\JKI\VIPM\Settings.ini

= Automated Message End =

 

= User Defined Message Start =

Activation Engine

= User Defined Message End =

 

= Error Handler Call Chain Start =

VIPM Splash.vi->

479EAF1BF9F9FFDA5C081E8552D0180F

= Error Handler Call Chain End =

=========== END of VIPM Error Message ===========

 

=========== START of VIPM Error Message ===========

An internal VIPM Error has occured on: zondag november 21, 2010 at 08:19:58

 

= Automated Message Start =

Error 8 occurred at Open/Create/Replace File in NI_LVConfig.lvlib:Save Config

File.vi->NI_LVConfig.lvlib:Close Config

Data.vi->D2AF3CFD834CE9396A74B0D8DC01EBD9.lvlib:904C5116343512B0F1A445FC303566DC->D2AF3CFD834CE9396A

74B0D8DC01EBD9.lvlib:EBEFD5019036D850028C955704BA6B8F->D2AF3CFD834CE9396A74B0D8DC01EBD9.lvlib:2CC72B

57BBF369809D4D91ABF47D2AD3->VIPM Splash.vi

Possible reason(s):

LabVIEW: File permission error. You do not have the correct permissions for the file.

=========================

NI-488: DMA hardware error detected.

C:\ProgramData\JKI\VIPM\Settings.ini

= Automated Message End =

 

= User Defined Message Start =

Error(s) Generated in Splash Window

= User Defined Message End =

 

= Error Handler Call Chain Start =

VIPM Splash.vi

= Error Handler Call Chain End =

=========== END of VIPM Error Message ===========

Share this post


Link to post
Share on other sites

As the title and topic description says...

 

When I start VIMP it crashes. It happens always (except after the installation of VIMP, so generally speaking I could also just reinstall and the problem is fixed for 1 time :))

 

When i check the log it tells me that there are some permissions issues. Now the error log seems pretty straightforward to me but I'm wondering how can I fix this?

 

Can you try running VIPM as administrator and see if that helps? It looks like you have a file permission issue.

 

Which version of windows are you using?

 

Thanks,

  • Upvote 1

Share this post


Link to post
Share on other sites

Can you try running VIPM as administrator and see if that helps? It looks like you have a file permission issue.

 

Which version of windows are you using?

 

Thanks,

Ah thanks! Running it as administrator solved the problem! I didn't (forgot to) tried that.

But to answer your question (don't know if you still need the info) i'm using windows 7.

Share this post


Link to post
Share on other sites

I'm happy to hear that you got this working.

 

You really shouldn't need to run as administrator in Windows 7 (but, it's a good work-around) -- there's probably a permissions issue with some of the files VIPM touches. I'll ping the JKI team and see about the official way to resolve this issue.

Share this post


Link to post
Share on other sites

Ah thanks! Running it as administrator solved the problem! I didn't (forgot to) tried that.

But to answer your question (don't know if you still need the info) i'm using windows 7.

Could you please check the permissions on a specific file for me? See attached image:

 

2010-11-22_11-03-27.png

Share this post


Link to post
Share on other sites

I don't have a group called "Authenticated Users" but the "SYSTEM" and "Administrators" group, they both have the same permissions as in your screenshot. The "users" group has only "read" & "read & execute" marked. What is strange is that one "group" is missing namely myself the user "WG-"

 

What I can tell you is this:

- When I change the permissions of the "users" group and mark all permissions, VIMP works without using "run as administrator". When I change it back it doesn't work anymore.

- When I add myself "WG-" to the permissions it works.

 

I think the problem could maybe within the installation at the moment when the files are exported and the permissions are set.

Share this post


Link to post
Share on other sites

Some questions:

  • Did you perform an upgrade on an earlier version of VIPM?
  • When you ran the VIPM 2010 installer. Did it run as administrator? You can tell because Windows would have asked you with an elevated permissions dialog (example here).

If the VIPM 2010 installer did not run with elevated administrator privileges in the first place, then this might be the problem.

I would like to know the answers to the above in order to prevent any future problems for new releases of VIPM. So your help is appreciated.

 

Just to wrap things up and fix your current problem. Do the following:

  1. Open an administrator level command line prompt in Windows. You can tell if it's administrator level because it will state: Administrator: C:\Windows\system32\cmd.exe in the titlebar. (more info here)
  2. Run the following command exactly as shown:
    cmd /C icacls C:\ProgramData\JKI /grant "Authenticated Users":(OI)(CI)F /T

This should solve your problem and you will be able from then on to run VIPM 2010 as a normal (non admin) user.

  • Upvote 1

Share this post


Link to post
Share on other sites

Some questions:

  • Did you perform an upgrade on an earlier version of VIPM?
  • When you ran the VIPM 2010 installer. Did it run as administrator? You can tell because Windows would have asked you with an elevated permissions dialog (example here).

If the VIPM 2010 installer did not run with elevated administrator privileges in the first place, then this might be the problem.

I would like to know the answers to the above in order to prevent any future problems for new releases of VIPM. So your help is appreciated.

 

Just to wrap things up and fix your current problem. Do the following:

  1. Open an administrator level command line prompt in Windows. You can tell if it's administrator level because it will state: Administrator: C:\Windows\system32\cmd.exe in the titlebar. (more info here)
  2. Run the following command exactly as shown:
    cmd /C icacls C:\ProgramData\JKI /grant "Authenticated Users":(OI)(CI)F /T

This should solve your problem and you will be able from then on to run VIPM 2010 as a normal (non admin) user.

 

Sorry for my (very) late reply. After the fix with the "run as administrator" it was solved for me. However...

 

The answer to the first question is definitely no. I just did a clean windows and LabVIEW install at that time. To the second question I can't really remember. But I would presume no.

 

Thirdly I still run it as administrator, as I said above. I just tried your fix but it didn't work. The shell command says something like (I can't translate it 1:1 to English), "Authenticated Users: There have been no allocations between any usernames or security-id's". So I would guess there is something wrong with the ""Authenticated Users":(OI)(CI)F /T"-part of the command. However I still fixed it because I set the privileges manually, I just thought I would let you know.

 

And FYI, I'm familiar with shell and windows however more with Linux then windows ^^

Share this post


Link to post
Share on other sites

What language is your Windows? Is it a non-english operating system? This might be the key to the problem.

 

However, I'm also concerned that it did not ask you permission to install VIPM. Have you disabled User Account Control in Windows?

Share this post


Link to post
Share on other sites

What language is your Windows? Is it a non-english operating system? This might be the key to the problem.

 

However, I'm also concerned that it did not ask you permission to install VIPM. Have you disabled User Account Control in Windows?

Yes my operating system is Windows and yes the language is set to, in my case, to Dutch.

 

About the second part. As I said I'm not very sure that it did ask permission, but I presumme that it didn't. And no user account control is not disabled in my Windows.

 

What I suggest is, is that I should maybe remove VIMP and try to install it again (However question from my side regarding this, when I remove VIMP, can't I use OpenG and the other things in VIMP then no more?)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.