Jump to content
Edgar Xu

VIPM 2010 could NOT connect to LabVIEW 2010

Recommended Posts

I'm using the latest version of VIPM (2010) and LabVIEW 2010. VIPM is unable to connect to LabVIEW 2010. I always get the error message "VIPM could not connect to LabVIEW 2010".

 

I followed the help, and verified that the VI Server Configuration settings are correct and that the VI Server Machine Access includes "127.0.0.1". I also tried the following without success:

 

1) Added "localhost" to VI Server Machine Access

2) Disabled my firewall

 

And the error record is:

 

=========== START of VIPM Error Message ===========

An internal VIPM Error has occured on: Tuesday March 08, 2011 at 08:21:03 am

 

= Automated Message Start =

Error 66 occurred at open Application Reference in 6AC7FC140B2D164FA74E67C20ECDDF97->VIPM Configure LV

Port.vi->F18E4D6A5A26A180AFCDF8C3D6B042C5->C6E98840855404BD53C49015460166D4->VIPM Main

Window.vi

Possible reason(s):

LabVIEW: The network connection was closed by the peer. If you are using the Open VI Reference

function on a remote VI Server connection, verify that the machine is allowed access by selecting

Tools>>Options>>VI Server:Machine Access on the server side.

 

= Automated Message End =

 

= User Defined Message Start =

Testing the LV connection from the test connection dialog.

= User Defined Message End =

 

= Error Handler Call Chain Start =

VIPM Main Window.vi->

C6E98840855404BD53C49015460166D4->

F18E4D6A5A26A180AFCDF8C3D6B042C5->

VIPM Configure LV Port.vi

= Error Handler Call Chain End =

=========== END of VIPM Error Message ===========

 

Any other ideas?

Edited by Edgar Xu

Share this post


Link to post
Share on other sites

I had the same problem using VIPM 2010 with LabVIEW 2010 SP1. Having followed Michael's advise, it seems that changing the "Machine Access" address to "127.0.0.1" did the trick. Thanks Michael.

 

-J.C..

 

 

This appears to be a problem with the settings in LabVIEW. Can you verify the settings are matching the attached image?

Also, can you disable any firewall anti-virus software temporarily to see if this has any affect?

Share this post


Link to post
Share on other sites

I am having the same issue. In the VI Package Manager, Tools, Options, LabVIEW, I am able to successfully test the connection to LabVIEW. However, in the VI Package Builder, when building a package I receive the error "VIPM could not connect to LabVIEW".

 

My LabVIEW configuration matches the above screenshot. I have tried adding "localhost" and "127.0.0.1" to the machine access list. I have also added VI Package Manager to my Firewall exceptions, and have disabled my antivirus. Still no success.

 

My system:

Windows 7 x64

LabVIEW 2010 x32

VI Package Manager 2010.0.2 build 1610

 

Thanks in advance for your help.

post-3726-0-91188700-1303417274_thumb.jpg

post-3726-0-55146500-1303417281_thumb.jpg

post-3726-0-22051500-1303417288_thumb.jpg

Share this post


Link to post
Share on other sites

I have a trouble installing the inferface with Aruiono The error message is as follows.

 

"Please verify the VI Server: Exported VIs and Machine Access setting in LabVIEW 2010. Make sure you are allowing access to VIPM by specifying "localhost" in the allowed list."

 

Although I have followed every step as described in https://decibel.ni.com/content/docs/DOC-15971, VIPM could not connet to LabVIEW 2010.Could you help me on this problem, please? Thank you.

Share this post


Link to post
Share on other sites

I still cannot solve the problem after following the setup in the video. I also attached the three status files below. Thank you for your help.

 

The only other thing I can think of is that LabVIEW access in being blocked by your firewall. Try turning it off.

Share this post


Link to post
Share on other sites

The only other thing I can think of is that LabVIEW access in being blocked by your firewall. Try turning it off.

 

Actually, I turned off my firewall and anti-virus when installing the interface with Arduino.

Share this post


Link to post
Share on other sites

Hello,

I am having trouble getting VIPM to connect to Labview 2010 (32bit) on a Win7 (64bit) system. I am using VIPM(1610) I have followed all of the posts that you have here and the instructions in the tutorial to no avail. Labview Launches but VIPM seems to time out before Labview is fully up. I am at a loss now as to what the fix is.. your last post did not seem to offer any solutions to the failure other than the ones already published. I have done all of these including renaming Labview ini, disabling the firewall, verified all settings in vi server setup etc as shown in the video tutorial.. none of this gets me going...

 

Thanks for your assistance.

Louis

Share this post


Link to post
Share on other sites

Hello,

I am having trouble getting VIPM to connect to Labview 2010 (32bit) on a Win7 (64bit) system. I am using VIPM(1610) I have followed all of the posts that you have here and the instructions in the tutorial to no avail. Labview Launches but VIPM seems to time out before Labview is fully up. I am at a loss now as to what the fix is.. your last post did not seem to offer any solutions to the failure other than the ones already published. I have done all of these including renaming Labview ini, disabling the firewall, verified all settings in vi server setup etc as shown in the video tutorial.. none of this gets me going...

 

Thanks for your assistance.

Louis

 

Have you tried extending the LabVIEW timeout value in the options?

2011-08-01_2308.png

Share this post


Link to post
Share on other sites

Hello,

 

I have the same problem, I tried with all this stuff, firewall, ports, Labview.ini, localhost IP, timeoutetc, etc but VIPM doesn't connect to LabVIEW. VIPM say me that I need to "Verify VI Server: Exported VIs and Machine Access setting in LabVIEW 2011"

 

How Can I fix it? I work with LV2011 and W7(64x).

 

Thanks

 

Have you tried extending the LabVIEW timeout value in the options?

noviembre-07-2011.txt

Share this post


Link to post
Share on other sites

Hello,

 

I have the same problem, I tried with all this stuff, firewall, ports, Labview.ini, localhost IP, timeoutetc, etc but VIPM doesn't connect to LabVIEW. VIPM say me that I need to "Verify VI Server: Exported VIs and Machine Access setting in LabVIEW 2011"

 

How Can I fix it? I work with LV2011 and W7(64x).

 

Thanks

 

 

 

Can you attach a screenshot of your labview VI Server Options?

 

 

 

Share this post


Link to post
Share on other sites

In the machine acces list is that IP address your IP on your local network? It needs to be.

Also, please add the following entries to the machine access list in addition to your existing IP address:

 

Entry: localhost

Entry: * (asterix)

 

No, It doesn't work, :( ,

 

Can I install the packages without this connection? I downloaded this packages but How I install it?

 

Thanks...

Share this post


Link to post
Share on other sites

It could be that another application is using port 3363 on your machine.

Can you try a few different number (on both LabVIEW and VIPM) to see if this help?

 

Note: you can find the list of all the listening ports by running (as an administrator) "netstat -a -b" in a command line prompt. Alternatively you can use Microsoft Sysinternals TCPView (which is graphical and update in real time).

 

Thanks

 

No, It's imposible to connect, I attach the new error file and the screenshoot with the error.

 

Thanks Michael.

Share this post


Link to post
Share on other sites

Hey, guys,

 

I am using VIPM2011 and LabVIEW 2011. And the operating system is Win Xp, unfortunately, same problem happened to me. My way is trying to run test in XP safe mode. Actually it is sucessful. When I return back to normal environment, I see the connection test result is yes but it is failed when installing the package.

I disable all of the startup items and firewall, anti-virus, whatever, it still doesn't work. something is conflict with VIPM?? Any suggestion?

 

Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.