Jump to content
Chris Reed

VIPM Not updating Packages

Recommended Posts

Dear JKI Team,

Firstly here is all my system info:

VIPM 2010 (2010.0.2) Community Version running through a ProxyServer

LabVIEW 2010 (v10.0)

Windows XP SP3

I attached an error log file - but that doesn't really relate to my current problem and I was blocked from attaching my Setting.ini file. I suppose I could paste it into the Topic if you really need it.

 

Anyway my problem is VIPM "seems" to be working through our Proxy Server, since when I check for All Package Repositories it goes off to ftp.ni.com and www.jkisoft.com and says that it did not find any updates for my installed packages - all good so far....

 

However on another outside laptop running through a Direct Connection with the same version of VIPM (but on Windows 7 Home with LV2010 SP1) it has just downloaded all the latest updates to the OpenG Library (ie. to version 4.x), but my version is still showing the old oglib_xxx library packages.

 

But then I look at say the MGI_General_VIs package and my version is at 3.8-10, but the laptop is at an earlier version of 3.4-2.

 

How can we tell what are the latest package versions and any idea why VIPM doesn't seem to be updating to the latest versions?

 

Thanks Chris

January-26-2011.txt

Share this post


Link to post
Share on other sites

VIPM only notifies you of updates to installed packages. If you haven't installed it then it won't notify you since the logic is that you only care about stuff you've installed.

 

After you've been notified of an update. You then need to install the package. If you don't then you will sit at whatever version you have installed. Just right-click the package to see all the versions under: Install Other. You can also install the latest version by just clicking 'upgrade' on the selected packages.

Share this post


Link to post
Share on other sites

Thanks for the reply Michael, but I have installed all the packages (as shown in the attached picture) and you can see under the Install Other Version it doesn't show the latest version of 4.0.0.5.

 

And if I click on Upgrade All Installed Packages it just tells me that all my packages are at the latest revision and No updates are required.

 

Chris

VIPM Screen Snapshot.jpg

Share this post


Link to post
Share on other sites

The only thing else I can think of is that perhaps the computer with the proxy is being blocked somehow from downloading the updates. This is strange because the update should fail in this case, but as you say, it's returning fine.

 

You can check the local cache to see if in fact any updates have been downloaded. You can look here:

C:\ProgramData\JKI\VIPM\cache

 

In there you should see the a file: *.ogpd

Open that file in a text editor and look to see if it contains the following text somewhere: Package oglib_variantconfig-4.0.0.5

 

If it does then that means that the info has been downloaded from the server and VIPM knows of the new version of variantconfig package. In this case, for some reason VIPM cannot display this in the UI. Strange. On the other hand, if you don't see this in the file, then you might have a connection issue with your network and the updates aren't getting downloaded.

Share this post


Link to post
Share on other sites

Hi Michael,

Well it looks like it might be a connection issue since this is the last package in the *.ogpd file

 

[Package oglib_variantconfig-2.7-2]

Package.URL=sf://opengtoolkit/oglib_variantconfig-2.7-2.ogp

Icon.URL=oglib_variantconfig-2.7-2.bmp

Spec.URL=oglib_variantconfig-2.7-2.spec

Package.MD5=d03e4825133cf42325d544563fe03565

Platform.Exclusive_LabVIEW_Version=>=6.1

Platform.Exclusive_OS=All

Dependencies.Requires=ogrsc_dynamicpalette>=0.2,oglib_lvdata>=2.0,oglib_string>=2.0,oglib_error>=2.0

 

But what I don't understand is that it doesn't report any errors when it goes off to the network to find the lastest packages. I can see the search paths come up in the Status bar and no Error file is saved in the Application Data directory. Also it "seems" that all(?) my other packages (eg. MGI) are up to date when compared to the Windows 7 (Direct Connection) Laptop.

 

Chris

Share this post


Link to post
Share on other sites

I think that the only packages that really have updates are the OpenG ones. You can also try renaming that file (to *.ogpd.bak) and see if a new one comes through.

 

It's also possible, that there is some caching going on between your computer and the source computer. So you are getting stale cached data.

Share this post


Link to post
Share on other sites

OK I tried renaming the *.ogpd file, but that didn't make any difference.

So then I copied the *.ogpd file from the Windows7 laptop that has the latest OpenG libraries and put it into my WinXP Desktop (with the old oglib libraries) and fired up VIPM again, but that didn't help him.

 

I'm not sure what you mean by caching on the Source Computer - do you mean the repository hosting the source files on the internet?

 

I have attached the two *.ogpd files, but they seem pretty much the same, although the Windows7 version is slightly larger.

 

Chris

ogpd files.zip

Share this post


Link to post
Share on other sites

OK tried that, but unfortunately none of my packages updated and it just recreated those two files again :(

 

To test the network connection I successfully downloaded and installed the Rename LVOOP Labels package :)

 

But then it didn't work when I tried to install the LabVIEW Interface for Arduino package :(

 

So I'm still not enitrely sure whether I can get out through our proxyserver. I will get our IT Dept. to investigate further.

 

Thanks for all your time and help Michael.

 

Chris

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.