Jump to content
Eldon Zacek

VIPM hangs when trying to install FPGA IP Digital Buses

Recommended Posts

When I select "FPGA IP Digital Buses, VIPM will display in the status bar "Resolving Package Dependencies". It will then proceed to sit there for an indefinite amount of time. This install is on a new Windows 7 platform with a fresh install of LabView. The same problem occurs whether the install is on 2011 or 2010 SP1. The only way to abort VIPM is to kill it with Task Manage. Then you have to reboot the PC because VIPM will not restart. By the way, CPU utilization goes to 50% on two of the four cores.

 

Any ideas?

Share this post


Link to post
Share on other sites

Hi Eldon,

 

Nice to hear from you! I hope things are going well in your neck of North Carolina :), but I'm sorry that VIPM is causing you grief :(.

 

You've discovered a bug in VIPM 2011.0.1's dependency resolution. It probably only affects a small number of packages, but unfortunately "FPGA IP Digital Buses" is one of them. We have reproduced the bug and are working on a fix, but I don't have a timetable for when it will be ready.

 

In the meantime, the only workaround I can give you is to downgrade back to VIPM 2011.0.0. Click here to download the old installer.

 

I apologize again for the trouble, and I hope downgrading (for now) isn't a huge hassle for you. If you need anything else please post back and we'll be glad to help.

 

Justin

Share this post


Link to post
Share on other sites

Justin,

 

Hope things are going well for you and you are enjoying the new addition to your family, would be about 2 now?

 

No big problem with the bug. Just wanted to let you know that it was happening.

 

The only other nuisance that I have seen is that if you select all of the OpenG addons, you will get a message about a conflict but no dialog on what the conflict is. If you select a subset then you will finally get the dialog showing and allowing you to select/deselect the appropriate libraries.

 

Sure hope NI starts having the technical seminars again!

 

Take care and have a Happy Holiday,

Eldon

Share this post


Link to post
Share on other sites

You've discovered a bug in VIPM 2011.0.1's dependency resolution. It probably only affects a small number of packages, but unfortunately "FPGA IP Digital Buses" is one of them. We have reproduced the bug and are working on a fix, but I don't have a timetable for when it will be ready.

 

In the meantime, the only workaround I can give you is to downgrade back to VIPM 2011.0.0. Click here to download the old installer.

 

Justin,

 

This problem also occurs when installing the Actor Framework Automated Message Class Creation Tool. Hopefully you can use this to help correct the issue.

 

Brian

Share this post


Link to post
Share on other sites

Hi Justin,

I think that the same problem occurs with:

  • ogrsc_rename_folder_of_vis 4.0.015
  • OpenG Error Library 4.2.0.23
  • OpeG LabVIEW Data Library 4.1.0.16
  • OpenG MD5 Digest Library 4.1.1.10
  • OpenG Numeric Library 4.1.0.8
  • OpenG String Library 4.1.0.12

 

I reproduce the same issue even with a fresh LabVIEW 2011 installation on Win 7 64-bit if I try to install one of these packages without any other package already installed.

I installed without problems other packages (OpenG, MGI, LAVA, ...).

 

Could you confirm that the old VIPM 2011.0.0 is not affected by this problem, please?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.