Jump to content
ColinR

Unable to save VI Package settings

Recommended Posts

Hello.

 

I periodically get the message "VIPM was unable to save your package settings. Please ensure that you have write privileges to every file in ... " where ... is the licensed library directory.

 

If I make another vipb file from scratch, it works fine. If I delete the directory and try to use the same vipb file, it does not. This is quite frustrating, as I have to go in and redo all of the icons and hierarchy settings. I've tried running VIPM as administrator, no dice. It appears to be a problem with the vipb file itself.

 

Ideas?

 

Thanks,

Colin

Share this post


Link to post
Share on other sites

I finally got around this by manually modifying the file permissions of the vipb file.

 

There must be an issue with a bad exit affecting permissions. I would guess that VIPM should have a way of unlocking the file by determining whether it's actually being used or not.

Share this post


Link to post
Share on other sites

Colin,

 

Thanks for providing the information on what fixed the issue. Can you provide the system configuration information (OS version etc) of the PC that is causing this issue? It will help us to investigate.

Share this post


Link to post
Share on other sites

Colin,

 

Thanks for providing the information on what fixed the issue. Can you provide the system configuration information (OS version etc) of the PC that is causing this issue? It will help us to investigate.

 

Windows 7 64-bit, updated as patches available. LV 2012 12.0f2 32-bit. VIPM 12.0.0 build 1780

 

Note unchecking 'read-only' was insufficient. Advanced options and granting full control solved issue. Granted full control to all users to fix, so unsure whether a subgroup would have solved the issue.

 

C

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.