Jump to content
Sign in to follow this  
Bob Schor

VIPM 2013 Pro "hangs" opening VIPC

Recommended Posts

I just installed (part of) LabVIEW 2013, which comes with VIPM 2013, to which I applied my Pro activation (seemed to "take"). I'm working on some code (doing documentation, fixing "spelling errors") that is distributed as a VIPC, and which installs its examples and some needed "utility features" (classes for generic plugins and some X Controls used to manage menus) in the local VIPM library.


I wanted to strip out just the Class utilities, as I have an up-to-date version of the actual code. I open VIPM, go to Window and "Show VIP Configuration Editor", then (in VIPC Editor) "Open an existing VIPC". When it opens, it shows me a dozen Yellow Cubes ("The entire package is stored inside the configuration file"), but I can't do anything with them. In particular, half of them are OpenG packages that are already in the VIPM window, a third are the older versions of the files I'm working with, and only 2 or three are the files I want to install in my Package Library (the list that VIPM shows me).


[it's always good to write complete documentation in a Forum, especially if you "write while doing". I was just going to say that if I right-click an entry and choose "Remove", nothing happens, but this time, it popped up a dialog and said something like "There are these other dependent packages here -- do you want me to remove them too?" I said "Yes", and then the "rest of the problem" popped up -- keep reading ...].


What happened this time is that the file and its associated dependents disappeared from the VIPC Editor window. At the same time, the cursor turned into the "spinning circle" ("Wait") cursor, and the Install Package and Uninstall Package icons in the VIPM toolbar started flashing at about 2 Hz. Needless to say, I cannot now exit either VIPM or VIPC Editor, except by using Task Manager to close the programs. In particular, neither Close button (X in upper right hand corner) works.


I'm running this on a Windows 7 (x64, fully upgraded and patched). This machine is fairly new (built within the past month), and has relatively little software on it. I have installed LabVIEW 2012 SP1 and LabVIEW 2013, both with LabVIEW RealTime and the Report Generator Toolkit.


Just for fun, I decided to see what happens if I re-run VIPM. I can't -- when I tried to close it, it somehow made the Windows Taskbar (at the bottom, with the Start button) disappear, and double-clicking on the VIPM shortcut on the desktop does nothing. I guess it's back to Ctrl-Alt-Del and asking Task Manager to reboot me. But first I'll send this off ...

Share this post

Link to post
Share on other sites

Quick followup -- on logging in again (not a Reboot, merely a Log Out), I found that the files I tried to Remove from the VIPC were still there (not a total surprise, as things "got stuck" after I clicked "Remove"). Also, the problem I had with the Start Menu disappearing was my own fault -- I'd mistakenly unlocked the Task Bar, and it was hidden along the top edge (instead of the bottom edge) of my window.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.