Jump to content
Ben64

VIPM update error

Recommended Posts

I get the following message when trying to update VIPM to version 2013 SP1

 

Error: The handle is in the wrong state for the requested operation

 

 

I also can't install any package, see attached file for error details.

 

 

LV2012 version 12.0f3 32-bit, Windows 7 Enterprise SP1 64-bit

 

 

Any idea of the cause?

VIPM errors.txt

Share this post


Link to post
Share on other sites

That first error message is related to the autoupdate. Perhaps the download is blocked by your company.

You can download the SP1 update directly from here.

 

The other error is something new that I've only seen a few times. VIPM is trying to install a package into LabVIEW and cannot because of permissions problems. This might happen because LabVIEW 2012 was installed with limited permissions.

 

Can you go to:

C:\Program Files (x86)\National Instruments\LabVIEW 2012\vi.lib\addons\

and look at what the permission setting is on that folder? That might give us a clue.

 

Normally LabVIEW is installed with open access to the vi.lib folder. So this is not a problem.

If permissions is an issue then you may be able to get it working by setting VIPM to launch with admin access. You can configure your VIPM to run using "Run As Administrator". You can also set this permanently in the security tab of the shortcut properties page:

2012-05-16_0954.png

  • Upvote 2

Share this post


Link to post
Share on other sites

That first error message is related to the autoupdate. Perhaps the download is blocked by your company.

You can download the SP1 update directly from here.

 

The other error is something new that I've only seen a few times. VIPM is trying to install a package into LabVIEW and cannot because of permissions problems. This might happen because LabVIEW 2012 was installed with limited permissions.

 

Can you go to:

C:\Program Files (x86)\National Instruments\LabVIEW 2012\vi.lib\addons\

and look at what the permission setting is on that folder? That might give us a clue.

 

Normally LabVIEW is installed with open access to the vi.lib folder. So this is not a problem.

If permissions is an issue then you may be able to get it working by setting VIPM to launch with admin access. You can configure your VIPM to run using "Run As Administrator". You can also set this permanently in the security tab of the shortcut properties page:

post-3-0-62932500-1387410624_thumb.png

 

 

Thanks Michael, your solutions worked for both issues.

 

Ben

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.