Jump to content
Bob Schor

Problem installing with LabVIEW 2013, Surface Pro

Recommended Posts

I'm having problems installing VIPM 13 on my Surface Pro (running Windows 8.1). This PC has LabVIEW 2012 and LabVIEW 2013 both installed. I had no trouble installing packages with LabVIEW 2012, but not with LabVIEW 2013.

 

I have (successfully) used VIPM on multiple PCs (typically Windows 7) and multiple versions of LabVIEW (including, recently, a PC with LabVIEW 2010, 2011, 2012, and 2013). For all these machines (and the current Surface under discussion), all the versions of LabVIEW are set up identically -- TCP/IP enabled, Port 3363, all TCP options "on", localhost and 127.0.0.1 enabled, all VIs enabled.

 

I've rebooted this PC, then opened VIPM and navigated to the "Version" option. I chose 2013, then had it "Verify". It successfully opened LabVIEW 2013, but about 2-3 seconds later, gave an error message that I'll look up right now ...

 

Here's what happens -- I open VIPM. select 2013 under Options, right-click, and and choose "Launch LabVIEW 2013". No problems. I then open Options, choose Configure LabVIEW Versions (for LabVIEW 2013), and click Verify. LabVIEW 2013 opens, then I get the error message "VIPM could not connect to LabVIEW 2013. Please verify the VI Server ...". On this screen, LabVIEW 2013 shows the correct port (3363), and, curiously, shows a checkmark in the Verified column. However, as I just noted, I cannot Verify (with the Verify button) nor can I install any packages.

 

While it will be a (minor) pain, I'm willing to uninstall VIPM, wipe out its folders, and start all over. However, I'll wait to see if you have any suggestions. I'll also "play around" a bit, and if I succeed, I'll post a follow-up.

 

Bob Schor

Share this post


Link to post
Share on other sites

Well, after several days of silence, I reopened my Surface and LabVIEW 2013 and "tweaked" various things that I didn't think mattered (like changing a firewall rule from "Auto" to "Allow", and enabling Scripting (which should not have mattered, I'd have thought). Maybe its the phase of the moon, but now it's installing.

Share this post


Link to post
Share on other sites

Bob,

 

Glad to know that you got it resolved. Also, apologies for not getting back to you sooner.

 

Also, thanks for the information. It will be great if you share more details of the things you tweaked. Other Surface users will be benefited from your experience.

Share this post


Link to post
Share on other sites

I'm having the same problem: LabVIEW 2012 works fine but LabVIEW 2013 cannot connect. Regardless of the timeout, the error appears shortly after LV2013 finishes launching. I have set the most liberal connection settings in VI Server to no avail.

 

Unfortunately, my firewall is managed but our IT, so I'm not able to fiddle and tweak it as easily. Handwaving in LabVIEW settings has not made any hits as well. Any suggestions on additional steps to try?

 

Well, after several days of silence, I reopened my Surface and LabVIEW 2013 and "tweaked" various things that I didn't think mattered (like changing a firewall rule from "Auto" to "Allow", and enabling Scripting (which should not have mattered, I'd have thought). Maybe its the phase of the moon, but now it's installing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.