Jump to content
dsmith

Missing dependencies that are not missing

Recommended Posts

Hi,

 

I've got a series of dependent packages which basically follows this format:

A

B depends on A

C depends on B

D depends on B and C

M1-M<N> depend on B, and potentially other packages

E1-E<N> depend on D and M<N>

 

Right now, I have an issue where VIPM shows a significant number of these pieces as broken. For example, a pair M1 and E1 are broken and shown below:

post-26976-0-32432300-1406565408_thumb.png

 

I click on the error button in the bottom right and it shows me these items as missing...and of course, all of them are not missing (except an unrelated one, which has its name erased in the image):

post-26976-0-13627100-1406565479_thumb.png

 

Can you help me identify what the actual problem is? I've taken a look at the spec page for the packages in the first image, and everything looks all right (ie the packages they are linked to are actually the package names I've installed). I've tried removing all old packages from the VIPM library. I've tried removing dependencies and re-adding them to my packages. I'm pretty much out of ideas.

 

Thanks,

Daniel

 

 

Edit: There also appear to be a few packages whose dependencies are not linking during install/uninstall. For example, I installed M2, and E2 did not uninstall. However when I ask M3 to uninstall, E3 correctly removes itself. For M2, I just opened the build spec, deleted all dependencies, added all dependencies back in, and the problem remains. The "Get info" function clearly shows the fact that it requires another package, but there is no right click option to "install missing dependencies".

Edited by dsmith

Share this post


Link to post
Share on other sites

Can you try this patched version and let me know if it fixes the issue?

Looks like that worked. Thanks a bunch.

 

 

Edit: yep, played with it some more and everything seems ok. Little false alarm where it turns out I made a package a dependency of itself, but everything seems to be working.

 

With this patch, is it something you're planning on rolling in to an update at some point? Will me having this patched version cause any issues? If I build .vipc files (which were not working before) and someone tries to install them, will they need to have this patched VIPM installed?

 

Thanks,

Daniel

Edited by Michael Aivaliotis

Share this post


Link to post
Share on other sites

With this patch, is it something you're planning on rolling in to an update at some point? Will me having this patched version cause any issues? If I build .vipc files (which were not working before) and someone tries to install them, will they need to have this patched VIPM installed?

No issues.

I'll be rolling it out today on VIPM Labs. But the fix won't be official until the next service pack release.

 

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.