Jump to content
Gavin Burnell

Error 5 when installing package in VIPM 2014

Recommended Posts

Under VIPM 2014 I'm getting intermittent cases of packages not installing with an error code 5. Installing into LV2012 sometimes I get an eror 5 (and obviously a failed installed), and then if I try again it installs cleanly. Sometimes it takes several goes to get a package to install. In LV 2013, it seems much harder to get it to install. The package in question is just an XControl, nothing particularly fancy, package built on the same version of VIPM.

 

If the error code is being passed through from LabVIEW then this would be a file already open error, and the intermittent nature would suggest a race condition somewhere.... any thoughts ?

Share this post


Link to post
Share on other sites

Gavin,

 

Your problem description is really never experienced by us. Especially when you mention that several attempts are needed installing a package.

 

Have you experienced this on same PC? Have you tried using VIPM on other PC?

Share this post


Link to post
Share on other sites

Sorry - forgot to check back on the bug report until now. Yes, so far this is just a problem on my work laptop. We have several desktop machines that I've had no problems with. One reason that I think it might be some race condition is that it got (a lot) worse when I got the hard disc on my laptop replaced with an SSD. I've tried turning off the anti-virus, but that doesn't seem to make difference.

Share this post


Link to post
Share on other sites

Not knowingly (!) As I said, it did happen before I got the SSD, but it's got a lot worse since I did. Other data point is that for legal reasons the laptop has full disk encryption (Sophos Safeguard) - it's supposed to be completely transparent to the software but....

 

I've manage to catch a screenshot as VIPM throws the error - the erro details text at the end is singularly unhelpful:

 

Main Package Name: Hierarchical Data Format (HDF5) v2.8.3.119

Package Name with Error: Hierarchical Data Format (HDF5) v2.8.3.119

Error Message: VIPM could not install the package h5labview2-2.8.3.119 .

Error Code: 5

Error Source:

===============

 

Here's the screenshot:post-2519-0-33897700-1417129874_thumb.jpeg

 

(and just for clarity, this happens on all packages and if I manually unzip the vipm, the file is there....)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.