Jump to content

VIPM loses Sourceforge database

Recommended Posts

I am having trouble with VIPM 2014(1955) on Mac OS X.


The SourceForgeMirrors.txt file is updated when it updates the package list. However this always seems to zero out the SourceForgeMirrors.txt file. This becomes an empty file and then VIPM tells me that I can't load from the OpenG or LV tools network.


The file should have the contents from the initial install listed at the end of this message. This is with "Mac" line endings or \r. If I go to the preferences and ask VIPM to update the source forge repository list the file then becomes a zero length empty file.




easynews: Phoenix, AZ (North America)

superb-west: Seattle, Washington (North America)

internap: San Jose, CA (North America)

superb-east: McLean, Virginia (North America)

voxel: New York, New York (North America)

puzzle: Bern, Switzerland (Europe)

mesh: Duesseldorf, Germany (Europe)

ovh: Paris, France (Europe)

dfn: Berlin, Germany (Europe)

heanet: Dublin, Ireland (Europe)

garr: Bologna, Italy (Europe)

surfnet: Amsterdam, The Netherlands (Europe)

kent: Kent, UK (Europe)

transact: Canberra, Australia (Australia)

internode: Adelaide, Australia (Australia)

waix: Perth, Australia (Australia)

jaist: Ishikawa, Japan (Asia)

nchc: Tainan, Taiwan (Asia)

ufpr: Curitiba, Brazil (South America)

Share this post

Link to post
Share on other sites

Hi Scott,


I can't seem to reproduce the issue. I'm running 1955 on Mac and click refresh mirrors and it tells me the list is up to date.




I press "OK" and everything seems to work just fine.



Share this post

Link to post
Share on other sites



Thanks for looking at this. I spent some time re-installing and testing over the weekend. It seems to be a permissions issue with /Library/Application Support/JKI.


If I install as one admin user, I cannot use VIPM as another admin user. Setting the group writable access on the files in /Library/Application Support/JKI does not help nor setting their group to admin. Then you get a message about cannot access the lab view updates. Not sure which file access triggers this. I even tried making things world writable but still no joy.


I did notice that the preference for "Network" does not default to "direct access" on the Mac but to "Use System Proxy Settings (Windows Only)" which is probably not what is needed. However it should use the system proxy settings in the network setup anyway.


Thanks for looking into this. I will just have to make sure that I use the same admin account for configuring VIPM.



Share this post

Link to post
Share on other sites



Thanks for detailed description of the problem.


We have recorded the issue as Case 16350 for internal tracking and debugging to identify and fix the problem.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.