Jump to content
Steen Schmidt

Package will install with less than required dependency version

Recommended Posts

Hi,

 

I've noticed that packages will install without complaint when all dependency packages can be found, but even if these dependencies are of lesser version than the minimum required as specified by the top-level package. I thought that VIPM would complain during install of such a package, if the minimum requirements of dependency versions weren't achieved? Why else include version in the dependencies list?

 

Example:

 

A.vip specifies a dependency 'B.vip >= 3.0.0.15'. A.vip will install happily even if B.vip is only available in version 2.0.0.10 for instance. I'd expected VIPM to tell me "Missing dependency" in this case.

 

Cheers,

Steen

Share this post


Link to post
Share on other sites

Steen,

 

We were not able to reproduce the behavior.

We tried using the available packages in VIPM and setting up the dependency for version mismatch. Package was built successfully and during the package installation, we received the message to update the dependent package and that was also installed successfully.

 

Can you help understand your scenario better?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.