Jump to content
_MaNYa_

VIPM 2017 for Linux won't Launch

Recommended Posts

I tried installing the new VIPM2017 for Linux in a clean Fedora 27 virtual machine just to give it a try but I can't get it to do anything. I followed the two basic steps:

1) install LVRTE 2015SP1 which installs without any problems or errors

2) copy JKI folder to /usr/local as described in the instruction.txt

When launching vipm I just get the blunt error: No such file or directory as shown below

sudo ./vipm
sudo: unable to execute ./vipm: No such file or directory

What could be the problem and how could it be resolved?

  • Like 1

Share this post


Link to post
Share on other sites

You need to run the executable:

sudo /user/local/JKI/VIPM/vipm

or change directories into the VIPM folder first and then run the executable

cd /user/local/JKI/VIPM
sudo ./vipm

The directions could be a little more clear.

Does that work for you?

Share this post


Link to post
Share on other sites

Thx for the reply.

Yes, I navigated into the /usr/local/JKI/VIPM directory first before launching the executable. I just tried with an absolute path (your first suggestion) and also as "root" instead of sudo, see below. All to no avail. I added a directory listing for reference.

[root@localhost /]# cd /usr/local/JKI/VIPM/
[root@localhost VIPM]# ./vipm 
bash: ./vipm: No such file or directory
[root@localhost VIPM]# ls -la
total 34536
drwxr-xr-x.  5 root root     4096 Mar  8 21:22 .
drwxr-xr-x.  3 root root     4096 Mar  8 21:22 ..
drwxr-xr-x. 10 root root    12288 Mar  8 21:22 help
drwxr-xr-x.  3 root root     4096 Mar  8 21:22 icons
-rw-r--r--.  1 root root   102497 Mar  8 21:22 License_Agreement.pdf
drwxr-xr-x.  6 root root     4096 Mar  8 21:22 support
-rw-r--r--.  1 root root       13 Mar  8 21:22 version
-rwxr-xr-x.  1 root root 35218160 Mar  8 21:22 vipm
-rw-r--r--.  1 root root       36 Mar  8 21:22 vipm.conf
[root@localhost VIPM]# 

 

Share this post


Link to post
Share on other sites

thanks for posting that.

It looks like you are in the right folder, the permissions are correct on the vipm file, and you tried to execute it. I'm no Linux expert, but that looks like it should work.

What happens if you type the following?

ls -al /usr/local/JKI/VIPM/vipm

This should output something that looks like:

-rwxr-xr-x.  1 root root 35218160 Mar  8 21:22 vipm

Share this post


Link to post
Share on other sites

Running the command produces the output below:

[root@localhost ~]# ls -al /usr/local/JKI/VIPM/vipm
-rwxr-xr-x. 1 root root 35218160 Mar  8 21:22 /usr/local/JKI/VIPM/vipm

In order to return the expected output, I have to "cd" into the folder and run the command slightly modified as found below:

[root@localhost ~]# cd /usr/local/JKI/VIPM/
[root@localhost VIPM]# ls -al vipm
-rwxr-xr-x. 1 root root 35218160 Mar  8 21:22 vipm

Let me know if there is anything else I could try or provide any other information.

Share this post


Link to post
Share on other sites

Some googling shows that this error can occur when you're running 64-bit and in order to run 32-bit executables, you'll need to install the ia32-libs package (and make sure you have multi-architecture support enabled).

You can try installing the ia32-libs package using the following command:

apt-get ia32-libs

Some googling will help you figure out all the details for your platform.

Disclaimer: I'm not a Linux expert, but I sometimes play one on TV.

Share this post


Link to post
Share on other sites

Much appreciate the help. The given command is for a debian based system and it seems there is no equivalent for the Fedora system I'm currently testing on. Fortunately I have a Ubuntu VM installation which I created earlier today. I switch to Fedora (Red Hat environment) because this the environment which is directly supported by NI installers.

Running the command produces the following output.

manya@ubuntuLV17:~$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32ncurses5 lib32z1

E: Package 'ia32-libs' has no installation candidate

I'm currently on Ubuntu 17.10 so perhaps this version is too new and therefor the package has been made obsolete as the output also mentioned.

Since it references 2 other package I installed those.

sudo apt-get install lib32ncurses5
sudo apt-get install lib32z1

When launching vipm I now have a different error message:

manya@ubuntuLV17:~$ sudo /usr/local/JKI/VIPM/vipm 
/usr/local/JKI/VIPM/vipm: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

So it seems some other lib is still missing that needs to be installed:

sudo apt-get install lib32stdc++6

Launching vipm once again produces the error below:

manya@ubuntuLV17:~$ sudo /usr/local/JKI/VIPM/vipm 
Can't find library liblvrt.so.15.0
Make sure this library is installed in your LD_LIBRARY_PATH
search path, or in /usr/lib
To download the LabVIEW Runtime engine, go to http://www.ni.com/rteFinder?dest=lvrte&version=15.0&platform=Linux&lang=en

Searching for liblvrt.so.15.0 shows the file is found in two locations (for my system):

/usr/local/lib64/liblvrt.so.15.0
/usr/local/lib64/LabVIEW-2015-64/liblvrt.so.15.0.1

Just by looking at the path it shows that this is a 64bit lib but vipm requires the 32bit version. As a "quick fix" I tried copying the libs to the expect location /usr/lib but as expected this doesn't work:

manya@ubuntuLV17:/etc/ld.so.conf.d$ sudo cp /usr/local/lib64/liblvrt.so.15.0 /usr/lib
manya@ubuntuLV17:/etc/ld.so.conf.d$ sudo /usr/local/JKI/VIPM/vipm 
Can't load library /usr/lib/liblvrt.so.15.0
/usr/lib/liblvrt.so.15.0: wrong ELF class: ELFCLASS64
To download the LabVIEW Runtime engine, go to http://www.ni.com/rteFinder?dest=lvrte&version=15.0&platform=Linux&lang=en

At this point I can only assume the easiest way forward is to create a 32bit Linux installation and retry the installation.

Or do you, @Jim Kring, have any other options to try out.

Share this post


Link to post
Share on other sites

You may need to do some googling and research to figure out how to run 32 bit applications on your linux installation.

there’s a discussion thread here with some tips:

https://stackoverflow.com/questions/23182765/how-to-install-ia32-libs-in-ubuntu-14-04-lts-trusty-tahr

Specifically, it talks about how to add another package repository for apt yet to find the missing package.

Please keep in mind that I’m not sure exactly if this is the best solution for you, so please be sure to do some research.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.