Jump to content
hooovahh

Package Dependency Not Found For Pre-Uninstall VI

Recommended Posts

If there is a dependency added to a Pre/Post Install/Uninstall VI, this dependency isn't detected by the Scan for Dependencies function.  Attached is a package that has a single VI that doesn't do much.  But the package has a Pre-Uninstall VI that has a dependency on an OpenG Wait.  Scanning for dependencies doesn't find any and I suspect it is because the Pre-Uninstall VI isn't part of the package source.  The reason I want this is because my Pre/Post Install/Uninstall VIs are getting large and I wanted to make subVIs but they aren't brought into the package, only the top level.  My work around for this is to call subVIs that are already installed.  I intended on making a single package that is something like "Package Tools" which all packages that use the Pre/Post VIs will depend on.  I can still add this manually but will often forget since all other dependencies are properly found on a scan.

Reuse Test.zip

Share this post


Link to post
Share on other sites

Hey Brian,

This is a great idea. You're right that VIPM doesn't scan the Custom Action VIs for dependencies, currently. I can see how that could be a big help.

We can't commit to a date on this, but I'll add it to our tracker, for the R&D team to consider.

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.