Jump to content
dhubbell

VI Package Manager Not Starting

Recommended Posts

VIPM worked before, but, now it will not start.  I have W10 Pro 64BIT, Running Labview 2018 Version 18.0.1f2.

If I try to run from my desktop, I see the VIPM Icon briefly, then it disappears. (See attached).

I next tried to use the "INSTALL" button from the jki.net website, this time I get an error message.  (See Attached).

Things I've tried:

  1. Run as Administrator
  2. Disable Anti-Virus
  3. Repair using the VIPM install program.
  4. Re-Install.
  5. Reboot.
  6. This URL:  https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P9YmSAK&l=en-US

Open to try suggestions.

Thank you,

Doug

Install From JKI website Gives this Error Message.jpg

Share this post


Link to post
Share on other sites

I was able to squeeze another error message out from the Desktop.  See Attached.

I thought this was going to work!  My NI PSP Service Locator wasn't started!  (See attached)

Same results, after I started the NI PSP Service Locator.  VIPM, didn't start.

NI Datafinder Error.jpg

NI PSP Service Locator.jpg

Share this post


Link to post
Share on other sites

I started looking around trying to figure out why VIPM wouldn't start.  I found the "Vi Package Manager.ini" file:

Quote

VI Package Manager]
AppFont=""Tahoma" 13"
useLocaleDecimalPt=FALSE
CurrentFont=""Tahoma" 13"
SystemFont=""Tahoma" 13"
DialogFont=""Tahoma" 13"
[General]
Note=" Settings moved to <windows common applicationdata>\\JKI\\VIPM\\Settings.ini"

l tried finding the "Settings.ini" file, nowhere on my computer is there a VIPM\Settings.ini file.

Could this missing "Settings.ini" be causing the VIPM to not start up?

 

Share this post


Link to post
Share on other sites

Another note, my OLD Windows 7 PC is running the latest version of VIPM with no problems, but, the old W7 Machine is running LV2015 and not LV2018.  I'm guessing it's a combination of W10 and/or LV2018 preventing VIPM from running correctly.

Share this post


Link to post
Share on other sites

How about this idea?

Could I install the package manually?  I mean if I install the package I want on another machine, how hard would it be to install/Copy it from one machine to the other?  My home PC has LV2018 with W7.  Seems W7 doesn't have a problem running VIPM.

Thanks!

Doug

Share this post


Link to post
Share on other sites

OK,  seems like there's a way to manually install the packages without the VIPM.  On my W10 machine the VIPM would not start, so I copied from a W7 VIPM to W10 machine manually.

As far as I can tell there are two main directories you'll need to copy:

C:\Program Files (x86)\National Instruments\LabVIEW 2018\menus\Categories\JKI Tools
This has the MENUS you'll need.

Next, there's the VI directory, you may need to open one of the VI's in the package to determine the location of VIs:
C:\Program Files (x86)\National Instruments\LabVIEW 2018\vi.lib\addons\_JKI.lib

W10 you gotta love it!  It's so efficient. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.