Jump to content
sblades

Hover Effect Inconsistent in 64 Bit Versions of LV

Recommended Posts

A mouse over hover effect has become standard in most major software UIs. This effect allows users to interact with controls in a more intuitive way and gives users confidence that they are making the selection that they intend. However there is a long standing NI bug that renders the hover effect inconsistent (see the discussion here: https://forums.ni.com/t5/LabVIEW/Button-Boolean-mouse-hover-not-working-on-64-Bit-LabVIEW/m-p/3944252#M1121887)

Until NI makes a fix one 'solution' that I will employ is to disable the hover effect with the controls that I am using so that users do not get confused by a control stuck in a hover state. 

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Note hover can be disabled programmatically, by writing to the last two elements of the "Colors[4]" property (note that if a button has hover colors, there will be actually 6 elements of this array)

  • 1 - FALSE
  • 2 - TRUE
  • 3 - Mouse Down when FALSE
  • 4 - Mouse Down when TRUE
  • 5 - Hovering when FALSE
  • 6 - Hovering when TRUE

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.