Jump to content
Sign in to follow this  
northrider

Can't install VIPM on RHEL8/LabVIEW 2019

Recommended Posts

The problem is with loading the LV2015 run-time supplied with vipm-17.0.2018-linux, which I tried to install on LV2019 Full for RedHat Enterprise Linux 8.

There are verification errors, easily dealt with running "sudo rpm -i --nodigest labview-2015-rte-15.0.1-11.x86_64.rpm",
and Most of the the other items (eg. nicurli) which refuse to install because the version 2019 .so libraries are newer can have appropriate
soft links added.

However, there is a basic architectural problem with nisvcloc.

Trying an install ( as the script would, except it needs "--nodigest" ) as: rpm -i --nodigest nisvcloc-15.0.0.1.noarch.rpm

Yields an error as:
"error: Failed dependencies:
    nisvcloc < 18.1.0 is obsoleted by (installed) ni-service-locator-19.0.0.49153-0+f1.x86_64"

WIth "rpm -ql nisvcloc-15.0.0-1.noarch.rpm" , the files are:

/usr/local/natinst/nisvcloc
/usr/local/natinst/nisvcloc/bin
/usr/local/natinst/nisvcloc/bin/nisvcloc
/usr/local/natinst/nisvcloc/bin/nisvcloc32
/usr/local/natinst/nisvcloc/bin/nisvcloc64
/usr/local/natinst/nisvcloc/etc
/usr/local/natinst/nisvcloc/init.d
/usr/local/natinst/nisvcloc/init.d/nisvcloc

Since the new ni-service-locator is a daemon under systemd, a simple soft link or manually adding the directories/files are not options.
The daemon executable is /usr/sbin/nisvcloc.

There isn't any directory structure as shown above for the nisvcloc rpm file at all.
IS there a workaround to install VIPM 2017 on RHEL 8 ?

Or do I need to wait for a new release to support LabVIEW 2019 Full for Linux ?

Thanks to all for your time in reading my post.

 

Edited by northrider
missing directory structure

Share this post


Link to post
Share on other sites

I am having the same experience using openSUSE.  When installing the LABVIEW 2015 RTE, there is this message:

error: Failed dependencies: nisvcloc < 18.1.0 is obsoleted by (installed) ni-service-locator-19.0.0.49152-0+f0.x86_64

Does anyone have a workaround for this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.