Jump to content
  • 0
Greg

Numeric Control (v2.0.1.28) field exceeds bounds of border

Question

When the user clicks in the numeric control box, the bounds of the white field exceed the border of the control

The user sees the background of the numeric control breaking through the border.

image.png.b6f9a1cbc964f75ab2699251e5a3e37e.png

 

Edited by Greg
error in uploaded image
  • Like 1

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Hi Greg. Thanks for posting this.

We are aware of this, and the only work-around we have found is to adjust the position of the display text down one pixel, relative to the other parts of the numeric control.

Unfortunately, that changes the position of the text relative to the background and it looks (very slightly) misaligned (it looks 1px too low). LabVIEW doesn’t provide much possibility for adjusting the behavior of the string text (like making the background transparent when it has the cursor for text input by user.

If you discover anything or have ideas about how to fix/improve this, please let us know.

does that explanation make sense?

Share this post


Link to post
Share on other sites
  • 0

Hi Jim. Thanks for your response. I'm still a little confused.

On my screen, the numeric control/indicator text is already too high (4 pixels of padding at the top and 8 at the bottom in the image below).

I will try moving the Numeric Text part down by entering Customize Mode in the control editing window.

image.png.f73de5b5332702ecc3c59d3a01120487.png

Edited by Greg
I think I know how to move the text location.

Share this post


Link to post
Share on other sites
  • 0

I think the issue *may* be the Application Font that's configured in LabVIEW/Windows on your computer -- I'd be curious to know more about that.

Here's how the numeric controls look on my system.

image.png

image.png

Share this post


Link to post
Share on other sites
  • 0

I am using Arial instead of the default font.

I think using the default font could cause appearance differences depending on OS of the computer running the VI. I am in a multi-OS environment, and I want to ensure a consistent UX. Please correct me if I am wrong.

Number Text field contains 28 pt font.

It's odd that LabVIEW fonts have different top and bottom padding.

What font are you using?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.