Jump to content

Recommended Posts

This is covered in part in various places but I thought it might be useful to have it in one.

I've got VIPM running on CentOS 8 but you have to jump through some hoops due to 64 bit, wayland and rpm signing!

1. Install support for the 32 bit RTE on 64 bit by installing the following packages:

glibc.i686
libstdc++.i686
libXinerama.i686
libGL.so.1

2. To install the run time engine - you need to remove the digest checks since these have got more strict. In the run time engine folder edit INSTALL so the line that starts RPMOPT includes --nodigest at the end of the string.

3. Now follow the standard install instructions.

4. Before running VIPM run the command "xhost si:localuser:root" to allow the root user to launch a window process. I believe this is due to wayland.

Hope that helps someone!

  • Like 1

Share this post


Link to post
Share on other sites

Hi James.

Thanks for posting this -- it's sure to be super helpful to VIPM users on Linux.

Ya, there are lots of little gotchas like this that pop up on various Linux flavors, and it's nice to have a record of what worked for others (or myself, when I find an old post of mine answering the question I'm now asking!).

-Jim

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.