Jump to content
Sign in to follow this  
Chris R

[FIXED] Proxy Settings

Recommended Posts

Hi JKI

 

Firstly can I congratulate you on the launch of VIPM, looks like a great upgrade for users of Commander. I certainly am looking forward to details of the Enterprise edition. :D

 

OK so the install of VIPM seemed to go quite smoothly, I successfully registered all versions of LabVIEW installed on my machine. When it came to setting the Proxy settings things didn't quite work out for me.

I have set proxy settings on Commander with no difficulties in the past however there is now a UserName and Password section. Becuase we use Novell Client Trust here at work I am already authenticated and therefore no Password U/name is required however when I clear the contents of the Password box and select OK they reappear if I then return to the Internet Settings page at any time.

 

In addition to this I also noticed that the list of mirror sites is empty as is the SourceForgeMirrors.txt file. Can I used the same file that is used by Commander ?

 

Any idea's how I can resolve this issue would be appreciated as I can't wait to get using VIPM.

 

Regards

Chris

Share this post


Link to post
Share on other sites

Hi Chris,

 

> Firstly can I congratulate you on the launch of VIPM, looks like a great upgrade for users of Commander. I certainly am looking forward to details of the Enterprise edition. :D

Thanks. The team has worked very hard on this release and it is nice to get this feedback!

 

> OK so the install of VIPM seemed to go quite smoothly, I successfully registered all versions of LabVIEW installed on my machine. When it came to setting the Proxy settings things didn't quite work out for me.

I have set proxy settings on Commander with no difficulties in the past however there is now a UserName and Password section. Becuase we use Novell Client Trust here at work I am already authenticated and therefore no Password U/name is required however when I clear the contents of the Password box and select OK they reappear if I then return to the Internet Settings page at any time.

 

This is just a display bug. The password field should be empty if there is no password configured, but it is currently being filled with 6 null characters (just for display). However, if you have not entered a username, then the HTTP request will not attempt to authenticate during proxy requests. I don't think that this bug is affecting you.

 

> In addition to this I also noticed that the list of mirror sites is empty as is the SourceForgeMirrors.txt file. Can I used the same file that is used by Commander ?

This should not be a problem. VIPM will automatically refresh the mirrors list, as needed. You can also refresh the list manually, by pressing the "Refresh Mirrors" button in the options dialog (see screenshot below).

 

refresh_mirrors.png

 

I am not really sure what could be the problem. Are you certain that the proxy host and port are correct and that you have a reasonable TCP timeout?

 

Regards,

 

-Jim

Share this post


Link to post
Share on other sites

Jim,

 

Many thanks for the speedy response, unfortunately I'm still scratching my head on this one. :D

 

> However, if you have not entered a username, then the HTTP request will not attempt to authenticate during proxy requests. I don't think that this bug is affecting you.

 

I have double and tripple checked my proxy settings, they are exactly the same (except no Username and Password) as those used by OGC. Perhaps your suggestion above is the root of my problems. If I am not entering a Username then no attempt is made to authenticate.

 

>I am not really sure what could be the problem. Are you certain that the proxy host and port are correct and that you have a reasonable TCP timeout?

 

Yep, I've checked them against my OGC settings and they're spot on. OGC is working so I know that I can connect.

 

Regards,

 

Chris

Share this post


Link to post
Share on other sites

Chris,

 

Can you see if there is an error log file here (or in a similar location, depending on your choice of installation location):

 

C:\Program Files\JKI\VI Package Manager\error\

 

And, if there are any error log files, could you please post them as an attachement, in this thread.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites
[uPDATE] This issue has been fixed (Case # 1941) and will appear in a future release. If anyone needs this issue resolved immediately, please send us an inquiry via our Sales, Customer Service, and Company Feedback form.

 

Please see the announcement, VI Package Manager 1.0 Beta 2 Released. This release has a fix for this issue.

 

Thank you,

 

-Jim

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.