Jump to content
Sign in to follow this  
vix

multiple labview registrtion in linux Suse 10.0

Recommended Posts

I have linux Suse 10.0 with LabVIEW 6.1 and 8.0 installed.

I installed VIPM 1.0 and I'm able to register LV 8.0 (TCP/IP port 3363) and successfully install package.

I can't register LV 6.1: if I use port 3363 I find a warning saying that there's another labview version on that port (and OK, there,'s the 8.0).

But if I change the port for LV 6.1 (as recommended, choosing for example 3364), in LV 8.0 the setting is automatically changed to 3364.

And if I change the setting in LV 8.0, the same TCP/IP port is automatically set in LV 6.1.

 

So I always have the same TCP/IP port for both the labview version, and the "Port Test" is successfullt only for LV 8.0.

 

Is there some known problem in registering two different labview version under linux?

 

Tks

Share this post


Link to post
Share on other sites
I have linux Suse 10.0 with LabVIEW 6.1 and 8.0 installed.

I installed VIPM 1.0 and I'm able to register LV 8.0 (TCP/IP port 3363) and successfully install package.

I can't register LV 6.1: if I use port 3363 I find a warning saying that there's another labview version on that port (and OK, there,'s the 8.0).

But if I change the port for LV 6.1 (as recommended, choosing for example 3364), in LV 8.0 the setting is automatically changed to 3364.

And if I change the setting in LV 8.0, the same TCP/IP port is automatically set in LV 6.1.

 

So I always have the same TCP/IP port for both the labview version, and the "Port Test" is successfullt only for LV 8.0.

 

Is there some known problem in registering two different labview version under linux?

 

Tks

 

Hi Tks,

 

On Linux, LabVIEW options for a user are stored in the home (~) directory, in a file called .labviewrc. This file is global for LabVIEW versions. However, you can (and should, in this case) create a labviewrc file in the (LabVIEW) program directory to store options that are the same for all users, such as the TCP port. For example, if you installed the LabVIEW files in /opt/labview, LabVIEW first reads options from /opt/labview/labviewrc. Note that entries in the .labviewrc file in your home directory override conflicting entries in the program directory, so you should make sure that the TCP port setting is not set in any user's .labviewrc file.

 

Please take a look at the Customizing Your Work Environment document (specifically, the Linux section) on ni.com for more details.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

Hi Jim,

thank you for your quick answer.

 

I had already read on the NI site the informations you remembered me, but there should be something wrong. Probably it's connected to a LabVIEW problem, but I let you know the situation.

I installed lv 6.1 in /user/local/lv61/ folder (the one proposed as default by the installer) and lv 8.0 in /user/local/natinst/labview/

In all my linux partition there isn't any labviewrc file, so I don't understand where labview stores its settings. I created a labviewrc file in /user/local/lv61/ and lv 6.1 loads this settings in the right way.

 

Reading the informations on the NI site, it seems that settings as the TCP-IP port should be in the labviewrc file in the two labview folders (/user/local/lv61/ and /user/local/natinst/labview/, correct?) but these files don't exist.

So I'm confused.... :huh:

on monday I'll try to check if they are hidden files, or something like that...

 

If you have any suggestions, you're welcome

 

Tks a lot

 

-Vix

Share this post


Link to post
Share on other sites

Hi Vix,

 

The labviewrc file(s) will probably not exist, already, in the labview installation folder(s). Try creating them, or copying them from your home directory. For example:

cp ~/.labviewrc /user/local/natinst/labview/labviewrc

 

Also, make sure that you don't have any settings in your .labviewrc file that overide the labviewrc files' settings. Just to be sure, you can try deleting your .labviewrc file.

 

rm ~/.labviewrc

 

Finally, you should be aware of file permissions. Make sure that the the labviewrc file in the labview installation folder is readable by users who will be running LabVIEW.

 

Let me know if this works for you.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

Thanks for your help.

I've found the .labviewrc file in the home directory, and I've noticed that it has got three kinds of entries:

- labview6

- labview8

- labview

 

Unfortunately the TCP/IP settings are in the labview group: so they're common to labview 6.1 and 8.0 :huh:

I've tried to duplicate the settings (labview6 and labview8) but this didn't work.

I've tried to move this settings in the .labviewrc files in the installation directories, but labview doesn't recognize them and re-write

labview.server.tcp.enabled and labview.server.tcp.port in the ~/.labviewrc file.

 

So I've started a topic in the NI forum, and I hope someone could help me...

 

-Vix

Share this post


Link to post
Share on other sites

Hi Vix,

 

Yes, at this point you will probably need NI support to help figure out what is happening. Please let us know if and how you are able to resolve this issue.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites
I've tried to duplicate the settings (labview6 and labview8) but this didn't work.

Hmmm - I was almost sure that would work. Please let us know how it all goes.

Share this post


Link to post
Share on other sites
Yes, at this point you will probably need NI support to help figure out what is happening. Please let us know if and how you are able to resolve this issue.

 

I tried on a fresh openSUSE 10.2 installation with LabVIEW 6.1 only, and I had the same "another labview version on the port" message.

So I'm not able to register lv 6.1, even if it's alone!!!

 

I noticed that when I enable the VI Server TCP/IP, every time I launch lv 6.1 I see the splash window completely black for 8-10 seconds, then labview starts correctly.

 

What could be the problem?

 

-Vix

Share this post


Link to post
Share on other sites
I tried on a fresh openSUSE 10.2 installation with LabVIEW 6.1 only, and I had the same "another labview version on the port" message.

So I'm not able to register lv 6.1, even if it's alone!!!

 

I noticed that when I enable the VI Server TCP/IP, every time I launch lv 6.1 I see the splash window completely black for 8-10 seconds, then labview starts correctly.

 

What could be the problem?

 

-Vix

 

Hi Vix,

 

Have you contacted NI support about this? I am pretty certain that it's an issue with LabVIEW.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites
Have you contacted NI support about this? I am pretty certain that it's an issue with LabVIEW.

 

yes, but they don't support LV 6.1 anymore... :huh:

and so, no help from NI...

 

Vix

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.