Jump to content
Sign in to follow this  
mcm

VIPM and no internet

Recommended Posts

Yes, you can easily do this. Take a look at this FAQ entry (which I just created):

Let me know if you have any questions.

 

Thanks,

 

-Jim

 

 

The above FAQ procedure did not work for me.

From VIPM the Tools>>Check the Network for Available Packages and the Package>>Download menu options

are grayed out. I asume that this is becaue I do not have Labview installed on the "Networked Computer"

Do you have any other options?

Share this post


Link to post
Share on other sites
The above FAQ procedure did not work for me.

From VIPM the Tools>>Check the Network for Available Packages and the Package>>Download menu options

are grayed out. I asume that this is becaue I do not have Labview installed on the "Networked Computer"

Do you have any other options?

 

Sorry for the continued trouble...

 

The Tools>>Check the Network for Available Packages and the Package>>Download menu option should be enabled, but it is not -- that's a bug (Case 4979, resolved in VIPM 1.1). However, you should still be able to press the Check the Network for Available Packages button on the toolbar (see screenshot below).

 

Check_Network_for_Packages.png

 

Now, for downloading the packages, you should be able to unselect the Show only Installable Packages in Package List option in order to display all the packages. However, this also appears to not be working unless a LabVIEW version is selected -- this is a bug (Case 4980, resolved in VIPM 1.1). This option selects whether to show only those packages that may be installed on the currently selected LabVIEW version or to show all packages that are available.

 

Unselect_Show_Only_Installable_Packages.png

 

Due to the aforementioned bug, we have to trick VIPM into thinking that you have LabVIEW installed. The steps listed below should work, but I have not tested them (since I have LabVIEW installed on all my computers)...

 

1) Close VIPM

 

2) Backup the "C:\Program Files\JKI\VI Package Manager\VI Package Manager.ini" file to a safe location.

 

3) Edit the "C:\Program Files\JKI\VI Package Manager\VI Package Manager.ini" file, adding (or updating) the following section and key-value pairs:

 

[Targets]
Names.<size(s)>=1
Names 0=LabVIEW
Versions.<size(s)>=6
Versions 0=6.1
Locations.<size(s)>=1
Locations 0=/C/Program Files/National Instruments/LabVIEW 6.1/LabVIEW.exe
Ports=<size(s)=1> 3363
Connection Timeout=60
Active Target.Name=LabVIEW
Active Target.Version=6.1

 

4) Launch VIPM

 

5) Select LabVIEW 6.1 from the version selector ring (see screenshot, below).

Select_6.1.png

 

6) Download the desired OpenG packages

 

Please let me know if you are able to make this work. If not, there are still some other work-arounds.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.