Jump to content
Sign in to follow this  
Jason D.

Error 1

Recommended Posts

EasyXML threw an Error 1:

Easy Parse XML

Input data is a null (empty) variant. You must wire valid data into the variant data input of the EasyXML VIs.

 

That's all well and good, but my data structure is huge, and the XML input string was created by a few previous calls to EasyXML with a very similar data structure. If EasyXML could add run-time information with the label of the offending control, then I could get this debugged a lot faster.

 

In the meantime, do you have any other advice? (I can't post the code here, sorry).

Edited by Jason D.

Share this post


Link to post
Share on other sites

Hi Jason,

 

Sorry to hear you're having trouble -- FYI, in a future version, we're planning to improve the error messages to provide better info about which data elements are causing the issues.

 

Regarding your example, it seems to work OK for me. Please, see the screenshot, below:

 

Test_Image.png

 

Also, which versions of the LabVIEW and OpenG/JKI packages are you using? Here's what I'm testing with:

 

LabVIEW 8.5.1

 

ogrsc_dynamicpalette-0.16-1

oglib_string-2.6-1

oglib_lvdata-2.8-1

oglib_error-2.3-2

oglib_array-2.7-1

nirsc_html_help_common-2.0-1

jki_rsc_toolkits_palette-1.1-1

jki_lib_easyxml-1.0-2

 

Thanks,

 

-Jim

 

PS - I deleted and replaced your attachment, since it had some default XML string data that didn't match your example data structure.

Share this post


Link to post
Share on other sites

Hi Jim:

 

I'm glad to see it is working for you. I just get Error 1 and an empty array.

 

I will check all of my packages later., but I haven't updated in a few weeks.

 

I have put in my own fixes for this OpenG issue, so I will look closely at that, and maybe try with a clean version of OpenG.

 

[Thanks for removing my default data from your site!]

 

Jason

Share this post


Link to post
Share on other sites
Also, which versions of the LabVIEW and OpenG/JKI packages are you using? Here's what I'm testing with:

 

LabVIEW 8.5.1

 

ogrsc_dynamicpalette-0.16-1

oglib_string-2.6-1

oglib_lvdata-2.8-1

oglib_error-2.3-2

oglib_array-2.7-1

nirsc_html_help_common-2.0-1

jki_rsc_toolkits_palette-1.1-1

jki_lib_easyxml-1.0-2

 

Thanks,

 

-Jim

 

PS - I deleted and replaced your attachment, since it had some default XML string data that didn't match your example data structure.

 

 

Here are the differences.

 

I am using LV 8.5

ogrsc_dynamicpalette-0.17-1

jki_lib_easyxml-1.0-1

 

VIPM says I am up to date, so I don't know how to get the newer version of EasyXML you have.

I have not yet backed out my OpenG fixes, but I will try that just to be sure.

Share this post


Link to post
Share on other sites

Just a quick comment:

 

jki_lib_easyxml-1.0-1 is the demo version

jki_lib_easyxml-1.0-2 is the paid version

 

We use this scheme, so that the paid version is always an upgrade to the demo version.

 

-Jim

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.