Jump to content
Sign in to follow this  
Arne

Error 10 in writing to xml-file

Recommended Posts

Hi

 

Is this a bug ??

 

Using Writing to xml file more than once (to the same file) gives an error 10. Try example "Write and Read XML File.vi". Switch "Delete File When Done (TRUE)" to off and run the VI twice...

 

"Error 10 occurred at Open/Create/Replace File in Easy Write XML File__JKI EasyXML.vi->Write and Read XML File.vi"

 

/arne

Share this post


Link to post
Share on other sites
Hi

 

Is this a bug ??

 

Using Writing to xml file more than once (to the same file) gives an error 10. Try example "Write and Read XML File.vi". Switch "Delete File When Done (TRUE)" to off and run the VI twice...

 

"Error 10 occurred at Open/Create/Replace File in Easy Write XML File__JKI EasyXML.vi->Write and Read XML File.vi"

 

/arne

 

Hi Arne,

 

Yes, this is the expected behavior.

 

The Easy Write XML File function writes the whole XML file. It does not append and it does not overwrite. In a future version we are considering adding an input that will allow you to select whether you want to overwrite existing files, without an error.

 

As a work-around, you might want to call Delete File before you write the file.

 

Sorry for the trouble.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

Hi Jim

 

No trouble at all. I just got puzzled over the Replace in

 

"Error 10 occurred at Open/Create/Replace File in Easy Write XML File__JKI EasyXML.vi->Write and Read XML File.vi"

 

My code works fine with Delete File before writing to the xml-file more than once.

 

 

Thank you

 

/arne

Share this post


Link to post
Share on other sites
No trouble at all. I just got puzzled over the Replace in

 

"Error 10 occurred at Open/Create/Replace File in Easy Write XML File__JKI EasyXML.vi->Write and Read XML File.vi"

 

My code works fine with Delete File before writing to the xml-file more than once.

 

You're right that this error message is confusing. We'll try to address that in a future release.

 

I'm glad you got it working :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.