Jump to content
HChandler

Can't use File>>Add Package(s)

Recommended Posts

Hi,

 

Where are you getting stuck? What's the last action that you are taking? What are you seeing and what did you expect to happen?

 

When I select File>>Add Package(s), I see the following dialog:

 

1.png

 

When you select packages and press Add, they should appear in your package list. If you don't see anything, make sure that you have selected a LabVIEW version selected:

 

2.png

 

If no LabVIEW versions are available, make sure that you've configured your LabVIEW versions in the Options dialog.

 

Let me know if this helps or if you still have questions.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites
I can't select the version because it wants to connect to the internet.

 

I can't use File>>AddPackages since it's grayed in the files menu.

 

Which VIPM version are you using (this can be found in the Help>About window)? I want to make sure that I'm testing with the same version as you.

 

Also, adding and selecting LabVIEW versions should not require connecting to the Internet. Is the LabVIEW Version selector grayed out?

 

And, the File>>Add Package(s) menu should not be disabled.

 

I'll try to do some more testing to see if I can reproduce your problem.

Share this post


Link to post
Share on other sites

I'm using the latest version. Downloaded late this afternoon. I'm not at work so I can't check.

 

I did everything as described in the referenced page. Up to step 4.

Edited by HChandler

Share this post


Link to post
Share on other sites
I'm using the latest version. Downloaded late this afternoon. I'm not at work so I can't check.

 

I did everything as described in the referenced page. Up to step 4.

 

When you get back into work, can you please take a screenshot of VIPM on your non-networked computer that shows the disabled menu items (that are preventing you from doing step #4)?

 

Thanks,

Share this post


Link to post
Share on other sites

I got it working. The trick was to click OK when the VIPM - configure LabVIEW Port dialog comes on. Even though it doesn't seem right to do this, you must anyway. How about a less confusing dialog for those who are in non-web mode?

 

Thanks for the help.

 

 

When you get back into work, can you please take a screenshot of VIPM on your non-networked computer that shows the disabled menu items (that are preventing you from doing step #4)?

 

Thanks,

Share this post


Link to post
Share on other sites
I got it working. The trick was to click OK when the VIPM - configure LabVIEW Port dialog comes on. Even though it doesn't seem right to do this, you must anyway. How about a less confusing dialog for those who are in non-web mode?

 

Thanks for the help.

 

I'm glad that you got it working.

 

And, thanks for the feedback. I agree that the way the checkbox and configure LabVIEW Port dialog work together are too confusing.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

One last thing. The instructions should say something about the need to have the tcpip port into LabView configured on both sides even if it's a local install. I was able to figure it out by the failure dialog when it timed out, but I did not realize that VIPM needed to talk to LV thru an ip port. Also, there might be firewall issues to warn about.

 

I'm glad that you got it working.

 

And, thanks for the feedback. I agree that the way the checkbox and configure LabVIEW Port dialog work together are too confusing.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites
One last thing. The instructions should say something about the need to have the tcpip port into LabView configured on both sides even if it's a local install. I was able to figure it out by the failure dialog when it timed out, but I did not realize that VIPM needed to talk to LV thru an ip port. Also, there might be firewall issues to warn about.

 

I see what you're saying.

 

We do put some indications of this requirement in the configure port dialog that pops up when you select a LabVIEW version checkbox:

 

1.png

 

Maybe we should add more documentation to the top of this dialog that says something like:

 

"In order for VIPM to manage LabVIEW, it needs to communicate with LabVIEW's VI Server over TCP-IP. Please configure and test the TCP-IP Port, below. After you have adjusted and tested the settings, press OK to accept the settings."

 

Would that help? Or, would you suggest something else?

 

Thanks,

Share this post


Link to post
Share on other sites

I can see now that the information is in the dialog pop up. For whatever reason, I thought it was about configuring tcpip ports for a transfer of data form JKI servers. The added words might be helpful. Also a couple of extra steps or some mention in the instructions (http://forums.jkisoft.com/index.php?showtopic=585) would have helped.

 

 

 

I see what you're saying.

 

We do put some indications of this requirement in the configure port dialog that pops up when you select a LabVIEW version checkbox:

 

post-2-1223308119_thumb.png

 

Maybe we should add more documentation to the top of this dialog that says something like:

 

"In order for VIPM to manage LabVIEW, it needs to communicate with LabVIEW's VI Server over TCP-IP. Please configure and test the TCP-IP Port, below. After you have adjusted and tested the settings, press OK to accept the settings."

 

Would that help? Or, would you suggest something else?

 

Thanks,

Share this post


Link to post
Share on other sites
I can see now that the information is in the dialog pop up. For whatever reason, I thought it was about configuring tcpip ports for a transfer of data form JKI servers. The added words might be helpful. Also a couple of extra steps or some mention in the instructions (http://forums.jkisoft.com/index.php?showtopic=585) would have helped.

Yes, I can see how having extra steps on the instructions would have helped. Those instructions do assume that you already know how to configure VIPM to talk to LabVIEW.

 

I've added a final step that should help with this:

 

7) Use VIPM to install the OpenG packages into LabVIEW. You should make sure to read this article, if you haven't already:

This article points to the getting started information that shows (among other things) how to configure VIPM to communicate with your installed LabVIEW versions.

 

Thanks again for all your feedback. I'm sure that this will help others, too.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.