Jump to content
Jason D.

Can't connect to LabVIEW with beta tookits

Recommended Posts

I'm trying to transition to LabVIEW 8.6, and I just installed VIPM 2.0.2 as well.

 

I'm trying to add LV 8.6 to VIPM, and I'm in the VIPM - Configure LabVIEW Port screen. I press the test button, and it fires up LabVIEW, which brings up an "evaluation software" dialog box, with the number of days remaining on the beta licenses. Before I can even click on "Launch LabVIEW", VIPM gives a failure message saying it can't connect to LabVIEW 8.6. Then I tried to increase the timeout from 90sec to 600sec. It still failed right away.

 

I didn't prove that the beta tookits are the problem, but it worked fine on my other (albeit non-Vista) machines.

 

After this, LabVIEW had actually started up. When I tried to hit TEST again, then it said LabVIEW was already running. I hit the "Quit LabVIEW" button and VIPM became unresponsive. I waited a minute or five and then killed it with the Task Manager.

 

I was able to make the connection by manually fixing the LabVIEW VI Server configuration.

 

Also, the error message says "Make sure you are allowing access to VIPM by specifiying "*" in the allowed list. It would be a lot safer to tell people to allow "localhost" rather than "*".

Share this post


Link to post
Share on other sites

Hi Jason,

> I didn't prove that the beta tookits are the problem, but it worked fine on my other (albeit non-Vista) machines.

 

When you say "beta toolkits" do you mean LabVIEW 8.6 beta or something else?

> Also, the error message says "Make sure you are allowing access to VIPM by specifiying "*" in the allowed list. It would be a lot safer to tell people to allow "localhost" rather than "*".

 

Thanks for the suggestion. I agree that we should recommend "localhost" instead of "*", as we do in the documentation, here:

 

http://jkisoft.com/vipm/docs/2.0/?turl=labview8x.htm

 

I've opened a bug (Case 6237) for this.

 

Thanks,

 

-Jim

Share this post


Link to post
Share on other sites

> I didn't prove that the beta tookits are the problem, but it worked fine on my other (albeit non-Vista) machines.

 

When you say "beta toolkits" do you mean LabVIEW 8.6 beta or something else?

 

Not the LV 8.6 beta, but the LabVIEW Software Engineering Tools beta (Trace Execution Toolkit and Unit Test Framework).

Share this post


Link to post
Share on other sites
Not the LV 8.6 beta, but the LabVIEW Software Engineering Tools beta (Trace Execution Toolkit and Unit Test Framework).

 

JKI doesn't have access to the LabVIEW Software Engineering Tools beta, in order to test this issue. Is there a way to have this "evaluation software" dialog go away (such as a "don't show me again" checkbox) until after the beta expires? Otherwise, your manual work-around is probably the best approach.

Share this post


Link to post
Share on other sites
JKI doesn't have access to the LabVIEW Software Engineering Tools beta, in order to test this issue. Is there a way to have this "evaluation software" dialog go away (such as a "don't show me again" checkbox) until after the beta expires? Otherwise, your manual work-around is probably the best approach.

 

I don't think the popup can be suppressed. But if VIPM could just wait longer to connect, everything would work. Even though there is a 90second timeout, VIPM puts up an error message box before I can even hit the "launch" button on the NI popup. (it's not really urgent; i'm just suggesting an improvement for a future release).

Share this post


Link to post
Share on other sites
Is there a way to have this "evaluation software" dialog go away (such as a "don't show me again" checkbox) until after the beta expires?

Yes - there's a check box in the bottom left corner of that window - check that and you should be fine.

Share this post


Link to post
Share on other sites
Yes - there's a check box in the bottom left corner of that window - check that and you should be fine.

 

You're right, the check box is there. However I still think this is a minor bug in VIPM. If it could just wait the requested timeout then there would be no need for a workaround.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.